blob: 3763923505533b311da17f3e3bdd6686cea06515 [file] [log] [blame]
Joel Stanley7259c7d2019-11-04 23:43:51 +10301SUMMARY = "eCMD"
2DESCRIPTION = "eCMD is a hardware access API for IBM Systems"
3LICENSE= "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${S}/NOTICE;md5=fee220301a2af3faf8f211524b4248ea"
5
6SRC_URI = "git://github.com/open-power/eCMD.git"
Joel Stanleyac6d51c2020-01-03 13:53:18 +11007SRCREV = "b858b2f212bda2665ad41e821302e8196c7aec07"
Brad Bishopb3fceb32020-01-17 11:14:37 -05008DEPENDS += "zlib"
Joel Stanley7259c7d2019-11-04 23:43:51 +10309
Joel Stanley5f2105b2019-11-05 11:25:16 +103010SRC_URI += "file://croserver.service"
11
Joel Stanley7259c7d2019-11-04 23:43:51 +103012S = "${WORKDIR}/git"
13
Brad Bishopb3fceb32020-01-17 11:14:37 -050014inherit pythonnative
15
Joel Stanley7259c7d2019-11-04 23:43:51 +103016do_configure() {
Joel Stanleyac6d51c2020-01-03 13:53:18 +110017 LD="${CXX}" ${S}/config.py --without-swig --output-root ${B} --target obj --extensions "cmd cip" --build-verbose
Joel Stanley7259c7d2019-11-04 23:43:51 +103018}
19
20do_compile() {
21 cd ${S}/dllNetwork/server
22 oe_runmake
23}
24
25do_install() {
26 install -d ${D}${bindir}
27 install -m 0755 out_obj/lib/server1p ${D}${bindir}/croserver
Joel Stanley5f2105b2019-11-05 11:25:16 +103028
29 install -d ${D}${systemd_system_unitdir}
30 install -m 0644 ${WORKDIR}/croserver.service ${D}${systemd_system_unitdir}/
Joel Stanley7259c7d2019-11-04 23:43:51 +103031}
Joel Stanley5f2105b2019-11-05 11:25:16 +103032
33FILES_${PN} += "${systemd_system_unitdir}/croserver.service"