blob: 01005f8fa06052cf64b8b5ec421a67da7974b57a [file] [log] [blame]
Joel Stanley7259c7d2019-11-04 23:43:51 +10301SUMMARY = "eCMD"
2DESCRIPTION = "eCMD is a hardware access API for IBM Systems"
3LICENSE= "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${S}/NOTICE;md5=fee220301a2af3faf8f211524b4248ea"
5
6SRC_URI = "git://github.com/open-power/eCMD.git"
7SRCREV = "6c0348b12c95b3bd6e8d8003f9ff743d25400ae2"
8DEPENDS += "python-native zlib"
9
Joel Stanley5f2105b2019-11-05 11:25:16 +103010SRC_URI += "file://croserver.service"
11
Joel Stanley7259c7d2019-11-04 23:43:51 +103012S = "${WORKDIR}/git"
13
14# Add the hash style option here to Work around this warning:
15# "QA Issue: No GNU_HASH in the elf binary"
16#
17# The recipe cannot set LDFLAGS in the environment as it overrides the
18# internal settings.
19do_configure() {
20 LD="${CXX} -Wl,--hash-style=gnu" ${S}/config.py --without-swig --output-root ${B} --target obj --extensions "cmd cip" --build-verbose
21}
22
23do_compile() {
24 cd ${S}/dllNetwork/server
25 oe_runmake
26}
27
28do_install() {
29 install -d ${D}${bindir}
30 install -m 0755 out_obj/lib/server1p ${D}${bindir}/croserver
Joel Stanley5f2105b2019-11-05 11:25:16 +103031
32 install -d ${D}${systemd_system_unitdir}
33 install -m 0644 ${WORKDIR}/croserver.service ${D}${systemd_system_unitdir}/
Joel Stanley7259c7d2019-11-04 23:43:51 +103034}
Joel Stanley5f2105b2019-11-05 11:25:16 +103035
36FILES_${PN} += "${systemd_system_unitdir}/croserver.service"