blob: 73269e7a0ed6a64663b05db856e9151822a8c146 [file] [log] [blame]
Lei YU216f4ea2020-07-16 08:16:59 +00001SUMMARY = "Enable USB ethernet"
2PR = "r1"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6DEPENDS += "systemd"
Lei YU05e5f0b2021-08-12 11:08:52 +08007RDEPENDS:${PN} += "libsystemd"
Lei YU216f4ea2020-07-16 08:16:59 +00008
9inherit allarch systemd
10
11SRC_URI += "file://usb_network.service \
12 file://00-bmc-usb0.network"
13
14do_install() {
15 install -d ${D}${systemd_unitdir}/system/
16 install -m 0644 ${WORKDIR}/usb_network.service ${D}${systemd_unitdir}/system
17
18 install -d ${D}${sysconfdir_native}/systemd/network/
19 install -m 0644 ${WORKDIR}/00-bmc-usb0.network ${D}${sysconfdir_native}/systemd/network
20}
21
22NATIVE_SYSTEMD_SUPPORT = "1"
23SYSTEMD_PACKAGES = "${PN}"
Lei YU05e5f0b2021-08-12 11:08:52 +080024SYSTEMD_SERVICE:${PN} = "usb_network.service"