blob: b3c491883c4861fcffc8715dc35992799a50599e [file] [log] [blame]
Deepak Kodihallifeb88672017-05-17 06:42:51 -05001SUMMARY = "Phosphor Settings Manager"
2DESCRIPTION = "Phosphor Settings Manager is an application that creates \
3d-bus objects to represent various user settings."
4PR = "r1"
Patrick Venture0e3e53b2018-10-26 08:55:27 -07005PV = "1.0+git${SRCPV}"
Deepak Kodihallifeb88672017-05-17 06:42:51 -05006
7inherit autotools
8inherit obmc-phosphor-dbus-service
Andrew Geissler384f1902020-04-02 13:11:28 +00009inherit python3native
Deepak Kodihallifeb88672017-05-17 06:42:51 -050010inherit phosphor-settings-manager
11
12require phosphor-settings-manager.inc
13
Patrick Williams12fc9392021-08-06 09:16:53 -050014DBUS_SERVICE:${PN} = "xyz.openbmc_project.Settings.service"
Deepak Kodihallifeb88672017-05-17 06:42:51 -050015
Andrew Geissler384f1902020-04-02 13:11:28 +000016DEPENDS += "${PYTHON_PN}-pyyaml-native"
17DEPENDS += "${PYTHON_PN}-mako-native"
Patrick Williams6aa2b122021-05-05 17:01:23 -050018DEPENDS += "${PYTHON_PN}-sdbus++-native"
Deepak Kodihallifeb88672017-05-17 06:42:51 -050019DEPENDS += "autoconf-archive-native"
20DEPENDS += "virtual/phosphor-settings-defaults"
Brad Bishopff92bb62020-07-09 16:59:54 -040021DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'obmc-mrw', 'phosphor-settings-read-settings-mrw-native', '', d)}"
Patrick Williams4b32c9a2020-03-31 16:43:15 -050022DEPENDS += "sdbusplus"
Patrick Williamsce14ef62020-06-09 21:00:08 -050023DEPENDS += "phosphor-dbus-interfaces"
Brad Bishopd55ffca2017-07-30 20:33:06 -040024DEPENDS += "phosphor-logging"
Brad Bishop17c08bf2018-10-18 17:07:53 -040025DEPENDS += "libcereal"
Deepak Kodihallifeb88672017-05-17 06:42:51 -050026
Deepak Kodihallifeb88672017-05-17 06:42:51 -050027S = "${WORKDIR}/git"
Deepak Kodihalli68136c32017-07-23 14:08:56 -050028SRC_URI += "file://merge_settings.py"
Deepak Kodihallifeb88672017-05-17 06:42:51 -050029
Konstantin Aladyshevd8154d02021-02-24 20:46:10 +030030# 'boot_type' configuration parameter is used to add support for
31# the Legacy/EFI boot override selector for systems with x86 host
32PACKAGECONFIG[boot_type] = ""
33SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'boot_type', 'file://boot_type.override.yml', '', d)}"
34
Deepak Kodihallifeb88672017-05-17 06:42:51 -050035EXTRA_OECONF = " \
36 SETTINGS_YAML=${STAGING_DIR_NATIVE}${settings_datadir}/defaults.yaml \
37 "
Deepak Kodihalli68136c32017-07-23 14:08:56 -050038
39# Collect files in SRC_URI that end in ".override.yml" and call a script that
40# writes their contents over that of settings.yaml, which is then updated to
41# the merged data values.
42# This doesn't correctly handle globs in ".override.yml" entries in SRC_URI.
43python do_merge_settings () {
44 import subprocess
45
46 # TODO: Perform the merge in a temporary directory?
47 workdir = d.getVar('WORKDIR', True)
48 nativedir = d.getVar('STAGING_DIR_NATIVE', True)
49 settingsdir = d.getVar('settings_datadir', True)
50 settingsdir = settingsdir[1:]
51 settingsdir = os.path.join(nativedir, settingsdir)
52 cmd = []
53 cmd.append(os.path.join(workdir, 'merge_settings.py'))
54 cmd.append(os.path.join(settingsdir, 'defaults.yaml'))
Gunnar Mills8c6516f2017-10-04 15:38:33 -050055 # Used for any settings from the MRW
Brad Bishopff92bb62020-07-09 16:59:54 -040056 use_mrw = bb.utils.contains('DISTRO_FEATURES', 'obmc-mrw', 'true', '', d)
Gunnar Mills8c6516f2017-10-04 15:38:33 -050057 if (use_mrw == 'true'):
58 cmd.append(os.path.join(settingsdir, 'mrw-settings.override.yaml'))
Deepak Kodihalli68136c32017-07-23 14:08:56 -050059
60 fetch = bb.fetch2.Fetch([], d)
Kun Yicdc3b232017-10-09 23:17:08 -070061 override_urls = [url for url in fetch.urls if url.endswith('.override.yml')]
Deepak Kodihalli68136c32017-07-23 14:08:56 -050062 for url in override_urls:
63 bb.debug(2, 'Overriding with source: ' + url)
64 local_base = os.path.basename(fetch.localpath(url))
65 filename = os.path.join(workdir, local_base)
66 cmd.append(filename)
67
68 # Invoke the script and don't catch any resulting exception.
69 subprocess.check_call(cmd)
70}
71# python-pyyaml-native is installed by do_configure, so put this task after
72addtask merge_settings after do_configure before do_compile