Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "World timezone definitions, modern and historical" |
| 2 | HOMEPAGE = "http://pythonhosted.org/pytz" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1a67fc46c1b596cce5d21209bbe75999" |
| 5 | |
| 6 | inherit pypi setuptools3 ptest |
| 7 | |
| 8 | SRC_URI[sha256sum] = "1e760e2fe6a8163bc0b3d9a19c4f84342afa0a2affebfaa84b01b978a02ecaa7" |
| 9 | |
| 10 | RDEPENDS:${PN}:class-target += "\ |
| 11 | ${PYTHON_PN}-datetime \ |
| 12 | ${PYTHON_PN}-doctest \ |
| 13 | ${PYTHON_PN}-io \ |
| 14 | ${PYTHON_PN}-pickle \ |
| 15 | ${PYTHON_PN}-pprint \ |
| 16 | ${PYTHON_PN}-threading \ |
| 17 | " |
| 18 | |
| 19 | BBCLASSEXTEND = "native nativesdk" |
| 20 | |
| 21 | SRC_URI += " \ |
| 22 | file://run-ptest \ |
| 23 | " |
| 24 | |
| 25 | RDEPENDS:${PN}-ptest += " \ |
| 26 | ${PYTHON_PN}-pytest \ |
| 27 | " |
| 28 | |
| 29 | do_install_ptest() { |
| 30 | install -d ${D}${PTEST_PATH}/pytz |
| 31 | install -d ${D}${PTEST_PATH}/pytz/tests |
| 32 | cp -rf ${S}/pytz/tests/* ${D}${PTEST_PATH}/pytz/tests/ |
| 33 | cp -f ${S}/README.rst ${D}${PTEST_PATH}/ |
| 34 | |
| 35 | } |