Ratan Gupta | 07a08c9 | 2018-09-03 08:41:52 +0530 | [diff] [blame] | 1 | SUMMARY = "NSS and PAM module for using LDAP as a naming service" |
| 2 | DESCRIPTION = "\ |
| 3 | daemon for NSS and PAM lookups using LDAP \ |
| 4 | This package provides a daemon for retrieving user accounts and similar \ |
| 5 | system information from LDAP. It is used by the libnss-ldapd and \ |
| 6 | libpam-ldapd packages but is not very useful by itself. \ |
| 7 | " |
| 8 | |
| 9 | HOMEPAGE = "http://arthurdejong.org/nss-pam-ldapd/" |
| 10 | |
| 11 | LICENSE = "LGPLv2.1" |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24" |
| 13 | SECTION = "base" |
| 14 | |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 15 | FILESEXTRAPATHS:prepend := "${THISDIR}/files:" |
Ratan Gupta | 07a08c9 | 2018-09-03 08:41:52 +0530 | [diff] [blame] | 16 | |
| 17 | SRC_URI = "\ |
| 18 | http://arthurdejong.org/nss-pam-ldapd/${BPN}-${PV}.tar.gz \ |
| 19 | file://nslcd.init \ |
| 20 | file://nslcd.service \ |
| 21 | " |
| 22 | |
| 23 | inherit autotools |
| 24 | |
| 25 | SRC_URI[md5sum] = "8c99fdc54f4bf9aca8c5f53fdb1403ff" |
| 26 | SRC_URI[sha256sum] = "ef7362e7f2003da8c7beb7bcc03c30494acf712625aaac8badc6e7eb16f3453f" |
| 27 | |
| 28 | DEPENDS += "libpam openldap krb5" |
| 29 | |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 30 | RDEPENDS:${PN} += "nscd" |
Ratan Gupta | 07a08c9 | 2018-09-03 08:41:52 +0530 | [diff] [blame] | 31 | |
| 32 | EXTRA_OECONF = "\ |
| 33 | --disable-pynslcd \ |
| 34 | --libdir=${base_libdir} \ |
| 35 | --with-pam-seclib-dir=${base_libdir}/security \ |
| 36 | " |
| 37 | |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 38 | CONFFILES:${PN} += "${sysconfdir}/nslcd.conf" |
Ratan Gupta | 07a08c9 | 2018-09-03 08:41:52 +0530 | [diff] [blame] | 39 | |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 40 | FILES:${PN} += "${base_libdir}/security ${datadir}" |
| 41 | FILES:${PN}-dbg += "${base_libdir}/security/.debug" |
Ratan Gupta | 07a08c9 | 2018-09-03 08:41:52 +0530 | [diff] [blame] | 42 | |
| 43 | LDAP_DN ?= "dc=my-domain,dc=com" |
| 44 | |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 45 | do_install:append() { |
Ratan Gupta | 07a08c9 | 2018-09-03 08:41:52 +0530 | [diff] [blame] | 46 | install -D -m 0755 ${WORKDIR}/nslcd.init ${D}${sysconfdir}/init.d/nslcd |
| 47 | |
| 48 | sed -i -e 's/^uid nslcd/# uid nslcd/;' ${D}${sysconfdir}/nslcd.conf |
| 49 | sed -i -e 's/^gid nslcd/# gid nslcd/;' ${D}${sysconfdir}/nslcd.conf |
| 50 | sed -i -e 's/^base dc=example,dc=com/base ${LDAP_DN}/;' ${D}${sysconfdir}/nslcd.conf |
| 51 | |
Brad Bishop | 57e15b1 | 2021-03-25 15:40:46 -0400 | [diff] [blame] | 52 | install -d ${D}${systemd_system_unitdir} |
| 53 | install -m 0644 ${WORKDIR}/nslcd.service ${D}${systemd_system_unitdir} |
Ratan Gupta | 07a08c9 | 2018-09-03 08:41:52 +0530 | [diff] [blame] | 54 | } |
| 55 | |
| 56 | inherit update-rc.d systemd |
| 57 | |
| 58 | INITSCRIPT_NAME = "nslcd" |
| 59 | INITSCRIPT_PARAMS = "defaults" |
| 60 | |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 61 | SYSTEMD_SERVICE:${PN} = "nslcd.service" |