blob: b569b593fc240047a649d5b54e4f94e7a9a6048c [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "OVMF - UEFI firmware for Qemu and KVM"
2DESCRIPTION = "OVMF is an EDK II based project to enable UEFI support for \
3Virtual Machines. OVMF contains sample UEFI firmware for QEMU and KVM"
4HOMEPAGE = "https://github.com/tianocore/tianocore.github.io/wiki/OVMF"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05005LICENSE = "BSD"
6LICENSE_class-target = "${@bb.utils.contains('PACKAGECONFIG', 'secureboot', 'BSD & OpenSSL', 'BSD', d)}"
Brad Bishop08902b02019-08-20 09:16:51 -04007LIC_FILES_CHKSUM = "file://OvmfPkg/License.txt;md5=06357ddc23f46577c2aeaeaf7b776d65"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008
9# Enabling Secure Boot adds a dependency on OpenSSL and implies
10# compiling OVMF twice, so it is disabled by default. Distros
11# may change that default.
12PACKAGECONFIG ??= ""
13PACKAGECONFIG[secureboot] = ",,,"
14
Brad Bishop08902b02019-08-20 09:16:51 -040015SRC_URI = "gitsm://github.com/tianocore/edk2.git;branch=master;protocol=git \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050016 file://0002-ovmf-update-path-to-native-BaseTools.patch \
17 file://0003-BaseTools-makefile-adjust-to-build-in-under-bitbake.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050018 file://0004-ovmf-enable-long-path-file.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019 file://no-stack-protector-all-archs.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050020 "
Brad Bishopd7bf8c12018-02-25 22:55:05 -050021
Brad Bishop08902b02019-08-20 09:16:51 -040022PV = "edk2-stable201905"
23SRCREV="20d2e5a125e34fc8501026613a71549b2a1a3e54"
24UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>edk2-stable.*)"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025
26inherit deploy
27
Brad Bishopd5ae7d92018-06-14 09:52:03 -070028PARALLEL_MAKE = ""
Brad Bishop6e60e8b2018-02-01 10:27:11 -050029
30S = "${WORKDIR}/git"
31
Brad Bishop19323692019-04-05 15:28:33 -040032DEPENDS_class-native="util-linux-native iasl-native"
Brad Bishop08902b02019-08-20 09:16:51 -040033DEPENDS_class-target="ovmf-native bc-native"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050034
35DEPENDS_append = " nasm-native"
36
37EDK_TOOLS_DIR="edk2_basetools"
38
39# OVMF has trouble building with the default optimization of -O2.
40BUILD_OPTIMIZATION="-pipe"
41
42# OVMF supports IA only, although it could conceivably support ARM someday.
43COMPATIBLE_HOST='(i.86|x86_64).*'
44
45# Additional build flags for OVMF with Secure Boot.
46# Fedora also uses "-D SMM_REQUIRE -D EXCLUDE_SHELL_FROM_FD".
47OVMF_SECURE_BOOT_EXTRA_FLAGS ??= ""
48OVMF_SECURE_BOOT_FLAGS = "-DSECURE_BOOT_ENABLE=TRUE ${OVMF_SECURE_BOOT_EXTRA_FLAGS}"
49
Brad Bishop08902b02019-08-20 09:16:51 -040050export PYTHON_COMMAND = "${HOSTTOOLS_DIR}/python3"
51
Brad Bishop6e60e8b2018-02-01 10:27:11 -050052do_patch[postfuncs] += "fix_basetools_location"
53fix_basetools_location () {
54}
55fix_basetools_location_class-target() {
56 # Replaces the fake path inserted by 0002-ovmf-update-path-to-native-BaseTools.patch.
57 # Necessary for finding the actual BaseTools from ovmf-native.
58 sed -i -e 's#BBAKE_EDK_TOOLS_PATH#${STAGING_BINDIR_NATIVE}/${EDK_TOOLS_DIR}#' ${S}/OvmfPkg/build.sh
59}
60
61do_patch[postfuncs] += "fix_iasl"
62fix_iasl() {
63}
64fix_iasl_class-native() {
65 # iasl is not installed under /usr/bin when building with OE.
66 sed -i -e 's#/usr/bin/iasl#${STAGING_BINDIR_NATIVE}/iasl#' ${S}/BaseTools/Conf/tools_def.template
67}
68
69# Inject CC and friends into the build. LINKER already is in GNUmakefile.
70# Must be idempotent and thus remove old assignments that were inserted
71# earlier.
72do_patch[postfuncs] += "fix_toolchain"
73fix_toolchain() {
74 sed -i \
75 -e '/^\(CC\|CXX\|AS\|AR\|LD\|LINKER\) =/d' \
76 -e '/^APPLICATION/a CC = ${CC}\nCXX = ${CXX}\nAS = ${AS}\nAR = ${AR}\nLD = ${LD}\nLINKER = $(CC)' \
77 ${S}/BaseTools/Source/C/Makefiles/app.makefile
78 sed -i \
79 -e '/^\(CC\|CXX\|AS\|AR\|LD\)/d' \
80 -e '/^VFR_CPPFLAGS/a CC = ${CC}\nCXX = ${CXX}\nAS = ${AS}\nAR = ${AR}\nLD = ${LD}' \
81 ${S}/BaseTools/Source/C/VfrCompile/GNUmakefile
82}
83fix_toolchain_append_class-native() {
84 # This tools_def.template is going to be used by the target ovmf and
85 # defines which compilers to use. For the GCC toolchain definitions,
86 # that will be ${HOST_PREFIX}gcc. However, "make" doesn't need that
87 # prefix.
88 #
89 # Injecting ENV(HOST_PREFIX) matches exporting that value as env
90 # variable in do_compile_class-target.
91 sed -i \
92 -e 's#\(ENV\|DEF\)(GCC.*_PREFIX)#ENV(HOST_PREFIX)#' \
93 -e 's#ENV(HOST_PREFIX)make#make#' \
94 ${S}/BaseTools/Conf/tools_def.template
95 sed -i \
96 -e '/^\(LFLAGS\|CFLAGS\) +=/d' \
97 -e '/^LINKER/a LFLAGS += ${BUILD_LDFLAGS}\nCFLAGS += ${BUILD_CFLAGS}' \
98 ${S}/BaseTools/Source/C/Makefiles/app.makefile \
99 ${S}/BaseTools/Source/C/VfrCompile/GNUmakefile
100 # Linking with gold fails:
101 # internal error in do_layout, at ../../gold/object.cc:1821
102 # make: *** [.../OUTPUT/Facs.acpi] Error 1
103 # We intentionally hard-code the use of ld.bfd regardless of DISTRO_FEATURES
104 # to make ovmf-native reusable across distros.
105 sed -i \
106 -e 's#^\(DEFINE GCC.*DLINK.*FLAGS *=\)#\1 -fuse-ld=bfd#' \
107 ${S}/BaseTools/Conf/tools_def.template
108}
109
110GCC_VER="$(${CC} -v 2>&1 | tail -n1 | awk '{print $3}')"
111
112fixup_target_tools() {
113 case ${1} in
114 4.4.*)
115 FIXED_GCCVER=GCC44
116 ;;
117 4.5.*)
118 FIXED_GCCVER=GCC45
119 ;;
120 4.6.*)
121 FIXED_GCCVER=GCC46
122 ;;
123 4.7.*)
124 FIXED_GCCVER=GCC47
125 ;;
126 4.8.*)
127 FIXED_GCCVER=GCC48
128 ;;
129 4.9.*)
130 FIXED_GCCVER=GCC49
131 ;;
132 *)
133 FIXED_GCCVER=GCC5
134 ;;
135 esac
136 echo ${FIXED_GCCVER}
137}
138
139do_compile_class-native() {
140 oe_runmake -C ${S}/BaseTools
141}
142
143do_compile_class-target() {
144 export LFLAGS="${LDFLAGS}"
Brad Bishop316dfdd2018-06-25 12:45:53 -0400145 PARALLEL_JOBS="${@oe.utils.parallel_make_argument(d, '-n %d')}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500146 OVMF_ARCH="X64"
147 if [ "${TARGET_ARCH}" != "x86_64" ] ; then
148 OVMF_ARCH="IA32"
149 fi
150
151 # The build for the target uses BaseTools/Conf/tools_def.template
152 # from ovmf-native to find the compiler, which depends on
153 # exporting HOST_PREFIX.
154 export HOST_PREFIX="${HOST_PREFIX}"
155
156 # BaseTools/Conf gets copied to Conf, but only if that does not
157 # exist yet. To ensure that an updated template gets used during
158 # incremental builds, we need to remove the copy before we start.
159 rm -f `ls ${S}/Conf/*.txt | grep -v ReadMe.txt`
160
161 # ${WORKDIR}/ovmf is a well-known location where do_install and
162 # do_deploy will be able to find the files.
163 rm -rf ${WORKDIR}/ovmf
164 mkdir ${WORKDIR}/ovmf
165 OVMF_DIR_SUFFIX="X64"
166 if [ "${TARGET_ARCH}" != "x86_64" ] ; then
167 OVMF_DIR_SUFFIX="Ia32" # Note the different capitalization
168 fi
169 FIXED_GCCVER=$(fixup_target_tools ${GCC_VER})
170 bbnote FIXED_GCCVER is ${FIXED_GCCVER}
171 build_dir="${S}/Build/Ovmf$OVMF_DIR_SUFFIX/RELEASE_${FIXED_GCCVER}"
172
173 bbnote "Building without Secure Boot."
174 rm -rf ${S}/Build/Ovmf$OVMF_DIR_SUFFIX
175 ${S}/OvmfPkg/build.sh $PARALLEL_JOBS -a $OVMF_ARCH -b RELEASE -t ${FIXED_GCCVER}
176 ln ${build_dir}/FV/OVMF.fd ${WORKDIR}/ovmf/ovmf.fd
177 ln ${build_dir}/FV/OVMF_CODE.fd ${WORKDIR}/ovmf/ovmf.code.fd
178 ln ${build_dir}/FV/OVMF_VARS.fd ${WORKDIR}/ovmf/ovmf.vars.fd
179 ln ${build_dir}/${OVMF_ARCH}/Shell.efi ${WORKDIR}/ovmf/
180
181 if ${@bb.utils.contains('PACKAGECONFIG', 'secureboot', 'true', 'false', d)}; then
Brad Bishop08902b02019-08-20 09:16:51 -0400182 # Repeat build with the Secure Boot flags.
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500183 bbnote "Building with Secure Boot."
184 rm -rf ${S}/Build/Ovmf$OVMF_DIR_SUFFIX
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500185 ${S}/OvmfPkg/build.sh $PARALLEL_JOBS -a $OVMF_ARCH -b RELEASE -t ${FIXED_GCCVER} ${OVMF_SECURE_BOOT_FLAGS}
186 ln ${build_dir}/FV/OVMF.fd ${WORKDIR}/ovmf/ovmf.secboot.fd
187 ln ${build_dir}/FV/OVMF_CODE.fd ${WORKDIR}/ovmf/ovmf.secboot.code.fd
188 ln ${build_dir}/${OVMF_ARCH}/EnrollDefaultKeys.efi ${WORKDIR}/ovmf/
189 fi
190}
191
192do_install_class-native() {
193 install -d ${D}/${bindir}/edk2_basetools
194 cp -r ${S}/BaseTools ${D}/${bindir}/${EDK_TOOLS_DIR}
195}
196
197do_install_class-target() {
198 # Content for UEFI shell iso. We install the EFI shell as
199 # bootx64/ia32.efi because then it can be started even when the
200 # firmware itself does not contain it.
201 install -d ${D}/efi/boot
202 install ${WORKDIR}/ovmf/Shell.efi ${D}/efi/boot/boot${@ "ia32" if "${TARGET_ARCH}" != "x86_64" else "x64"}.efi
203 if ${@bb.utils.contains('PACKAGECONFIG', 'secureboot', 'true', 'false', d)}; then
204 install ${WORKDIR}/ovmf/EnrollDefaultKeys.efi ${D}
205 fi
206}
207
208# This always gets packaged because ovmf-shell-image depends on it.
209# This allows testing that recipe in all configurations because it
210# can always be part of a world build.
211#
212# However, EnrollDefaultKeys.efi is only included when Secure Boot is enabled.
213PACKAGES =+ "ovmf-shell-efi"
214FILES_ovmf-shell-efi = " \
215 EnrollDefaultKeys.efi \
216 efi/ \
217"
218
Brad Bishop19323692019-04-05 15:28:33 -0400219DEPLOYDEP = ""
220DEPLOYDEP_class-target = "qemu-system-native:do_populate_sysroot"
Brad Bishop08902b02019-08-20 09:16:51 -0400221DEPLOYDEP_class-target += " ${@bb.utils.contains('PACKAGECONFIG', 'secureboot', 'openssl-native:do_populate_sysroot', '', d)}"
Brad Bishop19323692019-04-05 15:28:33 -0400222do_deploy[depends] += "${DEPLOYDEP}"
223
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500224do_deploy() {
225}
226do_deploy[cleandirs] = "${DEPLOYDIR}"
227do_deploy_class-target() {
228 # For use with "runqemu ovmf".
229 for i in \
230 ovmf \
231 ovmf.code \
232 ovmf.vars \
233 ${@bb.utils.contains('PACKAGECONFIG', 'secureboot', 'ovmf.secboot ovmf.secboot.code', '', d)} \
234 ; do
235 qemu-img convert -f raw -O qcow2 ${WORKDIR}/ovmf/$i.fd ${DEPLOYDIR}/$i.qcow2
236 done
Brad Bishop08902b02019-08-20 09:16:51 -0400237
238 if ${@bb.utils.contains('PACKAGECONFIG', 'secureboot', 'true', 'false', d)}; then
239 # Create a test Platform Key and first Key Exchange Key to use with EnrollDefaultKeys
240 openssl req -new -x509 -newkey rsa:2048 -keyout ${DEPLOYDIR}/OvmfPkKek1.key \
241 -out ${DEPLOYDIR}/OvmfPkKek1.crt -nodes -days 20 -subj "/CN=OVMFSecBootTest"
242 openssl x509 -in ${DEPLOYDIR}/OvmfPkKek1.crt -out ${DEPLOYDIR}/OvmfPkKek1.pem -outform PEM
243 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500244}
245addtask do_deploy after do_compile before do_build
246
247BBCLASSEXTEND = "native"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500248TOOLCHAIN = "gcc"