blob: cabb84e686dd2e4c5e8524d018db895c55f9d01b [file] [log] [blame]
Brad Bishop08902b02019-08-20 09:16:51 -04001SUMMARY = "Xlib: Compose data files for libx11"
2DESCRIPTION = "This package provides the compose data files for libx11."
3
4python () {
5 if bb.utils.contains('DISTRO_FEATURES', 'x11', True, False, d):
6 raise bb.parse.SkipRecipe("libx11-compose-data is incompatible with x11 distro feature, use libx11 instead.")
7}
8
9require xorg-lib-common.inc
10
11LICENSE = "MIT & MIT-style & BSD"
12LIC_FILES_CHKSUM = "file://COPYING;md5=172255dee66bb0151435b2d5d709fcf7"
13
14SRC_URI[md5sum] = "c5fa5a86a20e3591bed6c046498d4b8f"
15SRC_URI[sha256sum] = "b289a845c189e251e0e884cc0f9269bbe97c238df3741e854ec4c17c21e473d5"
16
17SRC_URI += "file://0001-Drop-x11-dependencies.patch"
18
19XORG_PN = "libX11"
20
21EXTRA_OECONF += "--disable-xkb"
22
23PACKAGES = "${PN}"
24
25FILES_${PN} = "${datadir}/X11/locale ${libdir}/X11/locale"
26
27do_compile() {
28 oe_runmake -C nls
29}
30
31do_install() {
32 oe_runmake DESTDIR=${D} -C nls install
33}
34
35REQUIRED_DISTRO_FEATURES = ""