Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Power usage tool" |
| 2 | DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management." |
| 3 | HOMEPAGE = "http://01.org/powertop/" |
| 4 | BUGTRACKER = "http://bugzilla.lesswatts.org/" |
| 5 | DEPENDS = "ncurses libnl pciutils" |
| 6 | LICENSE = "GPLv2" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e" |
| 8 | |
| 9 | SRC_URI = "http://01.org/sites/default/files/downloads/powertop-v${PV}.tar.gz \ |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame^] | 10 | file://0001-wakeup_xxx.h-include-limits.h.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | " |
| 12 | |
| 13 | SRC_URI[md5sum] = "a69bd55901cf919cc564187402ea2c9c" |
| 14 | SRC_URI[sha256sum] = "d3b7459eaba7d01c8841dd33a3b4d369416c01e9bd8951b0d88234cf18fe4a75" |
| 15 | |
| 16 | UPSTREAM_CHECK_URI = "https://01.org/powertop/downloads" |
| 17 | UPSTREAM_CHECK_REGEX = "powertop-[v]?(?P<pver>\d+(\.\d+)+)\.tar" |
| 18 | |
| 19 | inherit autotools gettext pkgconfig |
| 20 | |
| 21 | S = "${WORKDIR}/${BPN}-v${PV}" |
| 22 | |
| 23 | # we do not want libncursesw if we can |
| 24 | do_configure_prepend() { |
| 25 | # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one |
| 26 | sed -i -e "s/ncursesw//g" ${S}/configure.ac |
| 27 | mkdir -p ${B}/src/tuning/ |
| 28 | } |
| 29 | |
| 30 | inherit update-alternatives |
| 31 | ALTERNATIVE_${PN} = "powertop" |
| 32 | ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop" |
| 33 | ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop" |
| 34 | ALTERNATIVE_PRIORITY = "100" |