Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "Linux Trace Toolkit Userspace Tracer 2.x" |
| 2 | DESCRIPTION = "The LTTng UST 2.x package contains the userspace tracer library to trace userspace codes." |
| 3 | HOMEPAGE = "http://lttng.org/ust" |
| 4 | BUGTRACKER = "https://bugs.lttng.org/projects/lttng-ust" |
| 5 | |
| 6 | LICENSE = "LGPL-2.1-or-later & MIT & GPL-2.0-only" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a46577a38ad0c36ff6ff43ccf40c480f" |
| 8 | |
| 9 | PYTHON_OPTION = "am_cv_python_pyexecdir='${PYTHON_SITEPACKAGES_DIR}' \ |
| 10 | am_cv_python_pythondir='${PYTHON_SITEPACKAGES_DIR}' \ |
| 11 | PYTHON_INCLUDE='-I${STAGING_INCDIR}/python${PYTHON_BASEVERSION}${PYTHON_ABI}' \ |
| 12 | " |
| 13 | |
| 14 | inherit autotools lib_package manpages python3native pkgconfig |
| 15 | |
| 16 | include lttng-platforms.inc |
| 17 | |
| 18 | EXTRA_OECONF = "--disable-numa" |
| 19 | CPPFLAGS:append:arm = "${@oe.utils.vartrue('DEBUG_BUILD', '-DUATOMIC_NO_LINK_ERROR', '', d)}" |
| 20 | |
| 21 | DEPENDS = "liburcu util-linux" |
| 22 | RDEPENDS:${PN}-bin = "python3-core" |
| 23 | |
| 24 | # For backwards compatibility after rename |
| 25 | RPROVIDES:${PN} = "lttng2-ust" |
| 26 | RREPLACES:${PN} = "lttng2-ust" |
| 27 | RCONFLICTS:${PN} = "lttng2-ust" |
| 28 | |
| 29 | PE = "2" |
| 30 | |
| 31 | SRC_URI = "https://lttng.org/files/lttng-ust/lttng-ust-${PV}.tar.bz2 \ |
| 32 | file://0001-python-lttngust-Makefile.am-Add-install-lib-to-setup.patch \ |
| 33 | file://0001-lttng-ust-common-link-with-liburcu-explicitly.patch \ |
| 34 | file://0001-Makefile.am-update-rpath-link.patch \ |
| 35 | " |
| 36 | |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 37 | SRC_URI[sha256sum] = "f1d7bb4984a3dc5dacd3b7bcb4c10c04b041b0eecd7cba1fef3d8f86aff02bd6" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 38 | |
| 39 | CVE_PRODUCT = "ust" |
| 40 | |
| 41 | PACKAGECONFIG[examples] = "--enable-examples, --disable-examples," |
| 42 | PACKAGECONFIG[manpages] = "--enable-man-pages, --disable-man-pages, asciidoc-native xmlto-native libxslt-native" |
| 43 | PACKAGECONFIG[python3-agent] = "--enable-python-agent ${PYTHON_OPTION}, --disable-python-agent, python3, python3" |
| 44 | |
| 45 | FILES:${PN} += " ${PYTHON_SITEPACKAGES_DIR}/*" |
| 46 | FILES:${PN}-staticdev += " ${PYTHON_SITEPACKAGES_DIR}/*.a" |
| 47 | FILES:${PN}-dev += " ${PYTHON_SITEPACKAGES_DIR}/*.la" |
| 48 | |
| 49 | do_install:append() { |
| 50 | # Patch python tools to use Python 3; they should be source compatible, but |
| 51 | # still refer to Python 2 in the shebang |
| 52 | sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${bindir}/lttng-gen-tp |
| 53 | } |