blob: 82e3d006e45fe49a31bc6143a5df4fb07724ef62 [file] [log] [blame]
William A. Kennington IIIb95905d2021-06-02 12:40:56 -07001SUMMARY = "Tracker is a file search engine"
2LICENSE = "GPLv2 & LGPLv2.1"
3LIC_FILES_CHKSUM = " \
4 file://COPYING.GPL;md5=ee31012bf90e7b8c108c69f197f3e3a4 \
5 file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \
6"
7
8DEPENDS = " \
9 dbus-native \
10 glib-2.0 \
11 sqlite3 \
12 libarchive \
13 dbus \
14 icu \
15 json-glib \
16 libsoup-2.4 \
17 libstemmer \
18"
19
20GNOMEBASEBUILDCLASS = "meson"
21
22inherit gnomebase gsettings gobject-introspection vala gtk-doc manpages bash-completion features_check
23
24SRC_URI[archive.sha256sum] = "c120d81f2df94aa794b1a7953b55cfa46de318ed68e6f3b5ad4fce0c729c2483"
25
26# gobject-introspection is mandatory and cannot be configured
27REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
28UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
29
30# text search is not an option anymore and requires sqlite3 build with
31# PACKAGECONFIG[fts5] set (default)
32
33# set required cross property sqlite3_has_fts5
34do_write_config[vardeps] += "PACKAGECONFIG"
35do_write_config_append() {
36 echo "[properties]" > ${WORKDIR}/meson-tracker.cross
37 echo "sqlite3_has_fts5 = 'true'" >> ${WORKDIR}/meson-tracker.cross
38}
39
40EXTRA_OEMESON = " \
41 --cross-file ${WORKDIR}/meson-tracker.cross \
42 -Dman=false \
43 -Dsystemd_user_services=${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)} \
44 -Dsystemd_user_services_dir=${systemd_user_unitdir} \
45"
46
47FILES_${PN} += " \
48 ${datadir}/dbus-1 \
49 ${datadir}/tracker3 \
50 ${libdir}/tracker-3.0 \
51 ${systemd_user_unitdir} \
52"