Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "httplib2 caching for requests" |
| 2 | HOMEPAGE = "https://pypi.org/project/CacheControl/" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=6dc7e1b428eda03d850209fdbd6c71f1" |
| 5 | |
| 6 | # On PyPi, this is "CacheControl", rather than "cachecontrol", so we need to |
| 7 | # override PYPI_PACKAGE so fetch succeeds. |
| 8 | PYPI_PACKAGE = "CacheControl" |
| 9 | |
| 10 | SRC_URI[md5sum] = "5890b797f9b48b2b4cd1448cca89e396" |
| 11 | SRC_URI[sha256sum] = "be9aa45477a134aee56c8fac518627e1154df063e85f67d4f83ce0ccc23688e8" |
| 12 | |
| 13 | inherit pypi setuptools3 |
| 14 | |
| 15 | RDEPENDS_${PN} += "\ |
| 16 | python3-crypt \ |
| 17 | python3-datetime \ |
| 18 | python3-email \ |
| 19 | python3-lockfile \ |
| 20 | python3-json \ |
| 21 | python3-logging \ |
| 22 | python3-msgpack \ |
| 23 | python3-netclient \ |
| 24 | python3-pickle \ |
| 25 | python3-requests \ |
| 26 | python3-urllib3 \ |
| 27 | " |
| 28 | |
| 29 | BBCLASSEXTEND = "native nativesdk" |