blob: c033bd35274a569f98233402b878d5e4b7aa95f9 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Utility library to parse, compare, simplify and normalize license expressions"
2HOMEPAGE = "https://github.com/nexB/license-expression"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://apache-2.0.LICENSE;md5=e23fadd6ceef8c618fc1c65191d846fa"
6
Andrew Geisslerc87764f2020-06-27 00:16:32 -05007SRC_URI[md5sum] = "fd4cb295cc345be1071274cdbd81c969"
8SRC_URI[sha256sum] = "7960e1dfdf20d127e75ead931476f2b5c7556df05b117a73880b22ade17d1abc"
Brad Bishope42b3e32020-01-15 22:08:42 -05009
Andrew Geisslerc87764f2020-06-27 00:16:32 -050010inherit pypi ptest setuptools3
Brad Bishope42b3e32020-01-15 22:08:42 -050011
12RDEPENDS_${PN} += "\
13 ${PYTHON_PN}-booleanpy \
14 "
15
16BBCLASSEXTEND = "native nativesdk"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
18SRC_URI += " \
19 file://run-ptest \
20"
21
22RDEPENDS_${PN}-ptest += " \
23 ${PYTHON_PN}-pytest \
24"
25
26do_install_ptest() {
27 install -d ${D}${PTEST_PATH}/tests
28 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
29}