blob: f3b64174c4467e19c55b9254476ba70a2d17b2b6 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Name Service Switch module for Multicast DNS (zeroconf) name resolution"
2HOMEPAGE = "https://github.com/lathiat/nss-mdns"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003DESCRIPTION = "nss-mdns is a plugin for the GNU Name Service Switch (NSS) functionality of the GNU C Library (glibc) providing host name resolution via Multicast DNS (aka Zeroconf, aka Apple Rendezvous, aka Apple Bonjour), effectively allowing name resolution by common Unix/Linux programs in the ad-hoc mDNS domain .local."
Andrew Geissler82c905d2020-04-13 13:39:40 -05004SECTION = "libs"
5
6LICENSE = "LGPLv2.1+"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1"
8
9DEPENDS = "avahi"
10
11SRC_URI = "git://github.com/lathiat/nss-mdns \
12 "
13
Andrew Geissler09036742021-06-25 14:25:14 -050014SRCREV = "4b3cfe818bf72d99a02b8ca8b8813cb2d6b40633"
Andrew Geissler82c905d2020-04-13 13:39:40 -050015
16S = "${WORKDIR}/git"
17
18inherit autotools pkgconfig
19
20COMPATIBLE_HOST_libc-musl = 'null'
21
22EXTRA_OECONF = "--libdir=${base_libdir}"
23
24RDEPENDS_${PN} = "avahi-daemon"
25
26pkg_postinst_${PN} () {
27 sed '
28 /^hosts:/ !b
29 /\<mdns\(4\|6\)\?\(_minimal\)\?\>/ b
30 s/\([[:blank:]]\+\)dns\>/\1mdns4_minimal [NOTFOUND=return] dns/g
31 ' -i $D${sysconfdir}/nsswitch.conf
32}
33
34pkg_prerm_${PN} () {
35 sed '
36 /^hosts:/ !b
37 s/[[:blank:]]\+mdns\(4\|6\)\?\(_minimal\( \[NOTFOUND=return\]\)\?\)\?//g
38 ' -i $D${sysconfdir}/nsswitch.conf
39}