blob: b77bbd1fd4c2a080e462c758adb4396934cd5a57 [file] [log] [blame]
Andrew Geissler09036742021-06-25 14:25:14 -05001SUMMARY = "Perl-cross build system"
2HOMEPAGE = "https://github.com/arsv/perl-cross"
3DESCRIPTION = "perl-cross provides configure script, top-level Makefile and some auxiliary files for perl, \
4with the primary emphasis on cross-compiling the source."
5SECTION = "devel"
6LICENSE = "Artistic-1.0 | GPL-1.0+"
7# README.md is taken from https://github.com/arsv/perl-cross/blob/master/README.md
8# but is not provided inside the release tarballs
9LIC_FILES_CHKSUM = "file://${WORKDIR}/README.md;md5=252fcce2026b765fee1ad74d2fb07a3b"
10
11inherit allarch
12
13SRC_URI = "https://github.com/arsv/perl-cross/releases/download/${PV}/perl-cross-${PV}.tar.gz;name=perl-cross \
14 file://README.md \
15 file://0001-configure_tool.sh-do-not-quote-the-argument-to-comma.patch \
16 file://0001-perl-cross-add-LDFLAGS-when-linking-libperl.patch \
17 file://0001-configure_path.sh-do-not-hardcode-prefix-lib-as-libr.patch \
18 file://determinism.patch \
19 file://0001-cnf-configure_func_sel.sh-disable-thread_safe_nl_lan.patch \
20 "
21UPSTREAM_CHECK_URI = "https://github.com/arsv/perl-cross/releases/"
22
23SRC_URI[perl-cross.sha256sum] = "4010f41870d64e3957b4b8ce70ebba10a7c4a3e86c5551acb4099c3fcbb37ce5"
24
25S = "${WORKDIR}/perl-cross-${PV}"
26
27do_configure () {
28}
29
30do_compile () {
31}
32
33do_install_class-native() {
34 mkdir -p ${D}/${datadir}/perl-cross/
35 cp -rf ${S}/* ${D}/${datadir}/perl-cross/
36}
37
38BBCLASSEXTEND = "native"
39