blob: 89071b2a9749260e88cf9f4a6658634806112e81 [file] [log] [blame]
Andrew Geissler09036742021-06-25 14:25:14 -05001SUMMARY = "A library for property-based testing"
2HOMEPAGE = "https://github.com/HypothesisWorks/hypothesis/tree/master/hypothesis-python"
3LICENSE = "MPL-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4ee62c16ebd0f4f99d906f36b7de8c3c"
5
6PYPI_PACKAGE = "hypothesis"
7
8inherit pypi setuptools3
9
10SRC_URI[sha256sum] = "9bdee01ae260329b16117e9b0229a839b4a77747a985922653f595bd2a6a541a"
11
12RDEPENDS_${PN} += " \
13 python3-attrs \
14 python3-compression \
15 python3-core \
16 python3-json \
17 python3-sortedcontainers \
18 python3-statistics \
19 python3-unittest \
20 "
21
22BBCLASSEXTEND = "native nativesdk"