blob: 26fd9ac04970ae834b1130c0c49319c0a77cbcad [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "https://linux-test-project.github.io/"
4SECTION = "console/utils"
5LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
9 file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \
10 file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
11 file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
12 file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \
13 file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
14 file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
15"
16
17DEPENDS = "attr libaio libcap acl openssl zip-native"
18DEPENDS_append_libc-musl = " fts "
19EXTRA_OEMAKE_append_libc-musl = " LIBC=musl "
20EXTRA_OECONF_append_libc-musl = " LIBS=-lfts "
21
22# since ltp contains x86-64 assembler which uses the frame-pointer register,
23# set -fomit-frame-pointer x86-64 to handle cases where optimisation
24# is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer
25# earlier in CFLAGS, etc.
26CFLAGS_append_x86-64 = " -fomit-frame-pointer"
27
28CFLAGS_append_powerpc64 = " -D__SANE_USERSPACE_TYPES__"
29CFLAGS_append_mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
William A. Kennington IIIac69b482021-06-02 12:28:27 -070030SRCREV = "0fb171f2beddaf64bd27597577c206c0f892b3cd"
Andrew Geissler90fd73c2021-03-05 15:25:55 -060031
Andrew Geissler82c905d2020-04-13 13:39:40 -050032SRC_URI = "git://github.com/linux-test-project/ltp.git \
Andrew Geissler635e0e42020-08-21 15:58:33 -050033 file://0001-Remove-OOM-tests-from-runtest-mm.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050034 "
35
36S = "${WORKDIR}/git"
37
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050038inherit autotools-brokensep pkgconfig
Andrew Geissler82c905d2020-04-13 13:39:40 -050039
40TARGET_CC_ARCH += "${LDFLAGS}"
41
42export prefix = "/opt/${PN}"
43export exec_prefix = "/opt/${PN}"
44
45PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
46EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
Andrew Geissler635e0e42020-08-21 15:58:33 -050047EXTRA_OECONF = " --with-realtime-testsuite --with-open-posix-testsuite "
Andrew Geissler82c905d2020-04-13 13:39:40 -050048# ltp network/rpc test cases ftbfs when libtirpc is found
49EXTRA_OECONF += " --without-tirpc "
50
51do_install(){
52 install -d ${D}${prefix}/
Andrew Geisslerc926e172021-05-07 16:11:35 -050053 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install include-install
Andrew Geissler82c905d2020-04-13 13:39:40 -050054
55 # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run
56 # as it lacks dependency on some perl moudle such as LWP::Simple
57 # And this script previously works as a tool for analyzing failures from LTP
58 # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses
59 # http://khack.osdl.org to retrieve ltp test results run on
60 # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible
61 rm -rf ${D}${prefix}/bin/STPfailure_report.pl
62
63 # Copy POSIX test suite into ${D}${prefix}/testcases by manual
64 cp -r testcases/open_posix_testsuite ${D}${prefix}/testcases
65
66 # Makefile were configured in the build system
67 find ${D}${prefix} -name Makefile | xargs -n 1 sed -i \
68 -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \
69 -e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \
Andrew Geisslerc926e172021-05-07 16:11:35 -050070 -e 's@[^ ]*-ffile-prefix-map=[^ "]*@@g' \
71 -e 's@[^ ]*--sysroot=[^ "]*@@g'
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050072
73 # The controllers memcg_stree test seems to cause us hangs and takes 900s
74 # (maybe we expect more regular output?), anyhow, skip it
75 sed -e '/^memcg_stress/d' -i ${D}${prefix}/runtest/controllers
Andrew Geissler82c905d2020-04-13 13:39:40 -050076}
77
78RDEPENDS_${PN} = "\
79 attr \
80 bash \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050081 bc \
82 coreutils \
Andrew Geissler82c905d2020-04-13 13:39:40 -050083 cpio \
84 cronie \
85 curl \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050086 e2fsprogs \
Andrew Geissler82c905d2020-04-13 13:39:40 -050087 e2fsprogs-mke2fs \
88 expect \
89 file \
90 gawk \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050091 gdb \
Andrew Geissler82c905d2020-04-13 13:39:40 -050092 gzip \
93 iproute2 \
94 ldd \
95 libaio \
96 logrotate \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050097 net-tools \
Andrew Geissler82c905d2020-04-13 13:39:40 -050098 perl \
99 python3-core \
100 procps \
101 quota \
102 unzip \
103 util-linux \
104 which \
105 tar \
106"
107
108FILES_${PN} += "${prefix}/* ${prefix}/runtest/* ${prefix}/scenario_groups/* ${prefix}/testcases/bin/* ${prefix}/testcases/bin/*/bin/* ${prefix}/testscripts/* ${prefix}/testcases/open_posix_testsuite/* ${prefix}/testcases/open_posix_testsuite/conformance/* ${prefix}/testcases/open_posix_testsuite/Documentation/* ${prefix}/testcases/open_posix_testsuite/functional/* ${prefix}/testcases/open_posix_testsuite/include/* ${prefix}/testcases/open_posix_testsuite/scripts/* ${prefix}/testcases/open_posix_testsuite/stress/* ${prefix}/testcases/open_posix_testsuite/tools/* ${prefix}/testcases/data/nm01/lib.a ${prefix}/lib/libmem.a"
109
110# Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail
111INHIBIT_PACKAGE_STRIP_FILES = "${prefix}/testcases/bin/nm01 ${prefix}/testcases/bin/ldd01"
112INSANE_SKIP_${PN} += "already-stripped staticdev"
113
Andrew Geisslerc926e172021-05-07 16:11:35 -0500114remove_broken_musl_sources() {
115 [ "${TCLIBC}" = "musl" ] || return 0
116
117 cd ${S}
118 echo "WARNING: remove unsupported tests (until they're fixed)"
119
120 # sync with upstream
121 # https://github.com/linux-test-project/ltp/blob/master/travis/alpine.sh#L33
122 rm -rfv \
123 testcases/kernel/sched/process_stress/process.c \
124 testcases/kernel/syscalls/confstr/confstr01.c \
125 testcases/kernel/syscalls/fmtmsg/fmtmsg01.c \
126 testcases/kernel/syscalls/getcontext/getcontext01.c \
127 testcases/kernel/syscalls/rt_tgsigqueueinfo/rt_tgsigqueueinfo01.c \
128 testcases/kernel/syscalls/timer_create/timer_create01.c \
129 testcases/kernel/syscalls/timer_create/timer_create03.c \
130 utils/benchmark/ebizzy-0.3
131}
132do_patch[postfuncs] += "remove_broken_musl_sources"
133
Andrew Geissler82c905d2020-04-13 13:39:40 -0500134# Avoid file dependency scans, as LTP checks for things that may or may not
135# exist on the running system. For instance it has specific checks for
136# csh and ksh which are not typically part of OpenEmbedded systems (but
137# can be added via additional layers.)
138SKIP_FILEDEPS_${PN} = '1'