blob: 6759168b3726e257959202ecaa80abddef341d0f [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Provides a way to load and enumerate PKCS#11 modules"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = " Provides a standard configuration setup for installing PKCS#11 modules in such a way that they're discoverable. Also solves problems with coordinating the use of PKCS#11 by different components or libraries living in the same process."
3HOMEPAGE = "https://p11-glue.github.io/p11-glue/p11-kit.html"
Andrew Geissler82c905d2020-04-13 13:39:40 -05004LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://COPYING;md5=02933887f609807fbb57aa4237d14a50"
6
Andrew Geisslerd1e89492021-02-12 15:35:20 -06007inherit meson gettext pkgconfig gtk-doc bash-completion manpages
Andrew Geissler82c905d2020-04-13 13:39:40 -05008
9DEPENDS = "libtasn1 libtasn1-native libffi"
10
11DEPENDS_append = "${@' glib-2.0' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
12
Andrew Geissler09036742021-06-25 14:25:14 -050013SRC_URI = "git://github.com/p11-glue/p11-kit"
14SRCREV = "34826623f58399b24c21f1788e2cdaea34521b7b"
Andrew Geissler82c905d2020-04-13 13:39:40 -050015S = "${WORKDIR}/git"
16
17PACKAGECONFIG ??= ""
Andrew Geisslerd1e89492021-02-12 15:35:20 -060018PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxslt-native"
Andrew Geissler82c905d2020-04-13 13:39:40 -050019PACKAGECONFIG[trust-paths] = "-Dtrust_paths=/etc/ssl/certs/ca-certificates.crt,,,ca-certificates"
20
21GTKDOC_MESON_OPTION = 'gtk_doc'
22
23FILES_${PN} += " \
24 ${libdir}/p11-kit-proxy.so \
25 ${libdir}/pkcs11/*.so \
26 ${libdir}/pkcs11/*.la \
27 ${systemd_user_unitdir}/*"
28
29# PN contains p11-kit-proxy.so, a symlink to a loadable module
30INSANE_SKIP_${PN} = "dev-so"
31
32BBCLASSEXTEND = "nativesdk"