blob: 919d11417d360991fc6dc5cd7ff7f4f3a90204c5 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "A standalone native ldconfig build"
2
3LICENSE = "GPLv2+"
4
5LIC_FILES_CHKSUM = "file://${S}/ldconfig.c;endline=17;md5=1d15f20937c055cb5de2329a4c054399"
6
7SRC_URI = "file://ldconfig-native-2.12.1.tar.bz2 \
8 file://ldconfig.patch \
9 file://ldconfig_aux-cache_path_fix.patch \
10 file://32and64bit.patch \
11 file://endian-ness_handling.patch \
12 file://flag_fix.patch \
13 file://endianess-header.patch \
14 file://ldconfig-default-to-all-multilib-dirs.patch \
15 file://endian-ness_handling_fix.patch \
16 file://add-64-bit-flag-for-ELF64-entries.patch \
Andrew Geissler09209ee2020-12-13 08:44:15 -060017 file://no-aux-cache.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018"
19
20PR = "r2"
21
22FILESEXTRAPATHS =. "${FILE_DIRNAME}/${P}:"
23
24inherit native
25
26S = "${WORKDIR}/${PN}-${PV}"
27
28do_compile () {
29 $CC ldconfig.c -std=gnu99 chroot_canon.c xmalloc.c xstrdup.c cache.c readlib.c -I. dl-cache.c -o ldconfig
30}
31
32do_install () {
33 install -d ${D}/${bindir}/
34 install ldconfig ${D}/${bindir}/
35}