blob: 97b4ddb88b6b32b0fd02988d3884e8ae968ae905 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Initscript for auto-loading kernel modules on boot"
2SECTION = "base"
3LICENSE = "PD"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=7bf87fc37976e93ec66ad84fac58c098"
5SRC_URI = "file://modutils.sh \
6 file://PD.patch"
7
8PR = "r7"
9
10S = "${WORKDIR}"
11
12INITSCRIPT_NAME = "modutils.sh"
Andrew Geissler09209ee2020-12-13 08:44:15 -060013INITSCRIPT_PARAMS = "start 06 S ."
Patrick Williamsc124f4f2015-09-15 14:41:29 -050014
15inherit update-rc.d
16
17do_compile () {
18}
19
20do_install () {
21 install -d ${D}${sysconfdir}/init.d/
22 install -m 0755 ${WORKDIR}/modutils.sh ${D}${sysconfdir}/init.d/
23}
24
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025PACKAGE_WRITE_DEPS_append = " ${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd-systemctl-native','',d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026pkg_postinst_${PN} () {
Andrew Geissler475cb722020-07-10 16:00:51 -050027 if type systemctl >/dev/null 2>/dev/null; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -050028 if [ -n "$D" ]; then
29 OPTS="--root=$D"
30 fi
31 systemctl $OPTS mask modutils.service
32 fi
33}