Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Simple top-like I/O monitor" |
| 2 | DESCRIPTION = "iotop does for I/O usage what top(1) does for CPU usage. \ |
| 3 | It watches I/O usage information output by the Linux kernel and displays \ |
| 4 | a table of current I/O usage by processes on the system." |
| 5 | HOMEPAGE = "http://guichaz.free.fr/iotop/" |
| 6 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 7 | LICENSE = "GPLv2+" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4" |
| 9 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 10 | PV .= "+git${SRCPV}" |
| 11 | |
| 12 | SRCREV = "1bfb3bc70febb1ffb95146b6dcd65257228099a3" |
| 13 | SRC_URI = "git://repo.or.cz/iotop.git" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 16 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | UPSTREAM_CHECK_URI = "http://repo.or.cz/iotop.git/tags" |
| 18 | UPSTREAM_CHECK_REGEX = "iotop-(?P<pver>\d+(\.\d+)+)" |
| 19 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | inherit distutils3 |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 21 | |
| 22 | do_install_append() { |
| 23 | rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.pyo || true |
| 24 | rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.py || true |
| 25 | } |
| 26 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 27 | RDEPENDS_${PN} = "python3-curses \ |
| 28 | python3-codecs python3-ctypes python3-pprint \ |
| 29 | python3-shell python3-core" |