blob: c54dc946669fe395f386120ea7e032c6b347aa04 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "JSON C++ lib used to read and write json file."
2DESCRIPTION = "Jsoncpp is an implementation of a JSON (http://json.org) reader \
3 and writer in C++. JSON (JavaScript Object Notation) is a \
4 lightweight data-interchange format. It is easy for humans to \
5 read and write. It is easy for machines to parse and generate."
6
7HOMEPAGE = "https://github.com/open-source-parsers/jsoncpp"
8
9SECTION = "libs"
10
11LICENSE = "MIT"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=5d73c165a0f9e86a1342f32d19ec5926"
13
14PE = "1"
15
16SRCREV = "5defb4ed1a4293b8e2bf641e16b156fb9de498cc"
17SRC_URI = "git://github.com/open-source-parsers/jsoncpp;branch=master;protocol=https"
18
19S = "${WORKDIR}/git"
20
21inherit cmake
22
23EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON -DBUILD_OBJECT_LIBS=OFF -DJSONCPP_WITH_TESTS=OFF"
24
25BBCLASSEXTEND = "native"