Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | DESCRIPTION = "luaposix is a POSIX binding for Lua." |
| 2 | LICENSE = "MIT" |
| 3 | HOMEPAGE = "https://github.com/luaposix/luaposix" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f81069e00c0cad249f20efe958276db1" |
| 5 | |
| 6 | DEPENDS += "lua-native lua virtual/crypt" |
| 7 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 8 | SRC_URI = "git://github.com/luaposix/luaposix.git;branch=release-v${PV};protocol=https \ |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 9 | " |
| 10 | SRCREV = "14043c5086ae738823a5dfbc9170d9e14193fbef" |
| 11 | S = "${WORKDIR}/git" |
| 12 | LUA_VERSION = "5.4" |
| 13 | |
| 14 | B = "${S}" |
| 15 | |
| 16 | inherit pkgconfig |
| 17 | |
| 18 | do_compile() { |
| 19 | ${S}/build-aux/luke |
| 20 | } |
| 21 | |
| 22 | do_install() { |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 23 | ${S}/build-aux/luke PREFIX=${D}${prefix} INST_LIBDIR=${D}${libdir}/lua/${LUA_VERSION} install |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 24 | } |
| 25 | |
| 26 | FILES:${PN} = "${datadir}/lua/${LUA_VERSION} \ |
| 27 | ${libdir}/lua/${LUA_VERSION}" |