blob: a44774ea1edebcf10aea7581a4b98220a1e18919 [file] [log] [blame]
Marri Devender Rao53c55032017-07-26 02:11:32 -05001SUMMARY = "To merge the Host and BMC config files generated from MRW "
Nagaraju Goruganti0a01e9f2018-04-01 07:56:47 -05002DESCRIPTION = "Merge host provided FRU info config file, fru info config, \
3which is not sent by host config, and BMC accessible FRU info config \
4files generated by gen-ipmi-fru.pl into a single config file. \
5fru-gen parser parses the merged config file and generates cpp file"
Marri Devender Rao53c55032017-07-26 02:11:32 -05006PR = "r1"
7
8inherit native
9inherit phosphor-ipmi-host
10inherit obmc-phosphor-license
11
12DEPENDS += "virtual/phosphor-ipmi-fru-read-inventory"
13DEPENDS += "virtual/phosphor-ipmi-fru-read-bmc-inventory"
Nagaraju Goruganti0a01e9f2018-04-01 07:56:47 -050014DEPENDS += "virtual/phosphor-ipmi-fru-read-not-sent-by-host-inventory"
Marri Devender Rao53c55032017-07-26 02:11:32 -050015PROVIDES += "virtual/phosphor-ipmi-fru-merge-config"
16
17do_install_append() {
18 SRC=${config_datadir}
19 DEST=${D}${config_datadir}
20 install -d ${DEST}
21 cat ${SRC}/config.yaml ${SRC}/bmc-fru-config.yaml > ${DEST}/fru_config.yaml
Nagaraju Goruganti0a01e9f2018-04-01 07:56:47 -050022 cat ${SRC}/fru-config-not-sent-by-host.yaml >> ${DEST}/fru_config.yaml
Marri Devender Rao53c55032017-07-26 02:11:32 -050023}