blob: 3c5e36fce7059716d561b48779e8c822e3b0df39 [file] [log] [blame]
Marri Devender Rao7b823182017-06-08 03:17:36 -05001SUMMARY = "Generate inventory map for phosphor-ipmi-host from a MRW."
2PR = "r1"
3
4inherit native
5inherit phosphor-ipmi-host
Matt Spinler0a8ea632017-12-14 13:31:55 -06006inherit mrw-xml
Marri Devender Rao7b823182017-06-08 03:17:36 -05007
8require phosphor-ipmi-host.inc
9
10DEPENDS += "mrw-native mrw-perl-tools-native"
11
12DEPENDS += "virtual/phosphor-ipmi-fru-hostfw-config"
13PROVIDES += "virtual/phosphor-ipmi-fru-read-inventory"
14
Marri Devender Rao4d127802017-07-05 12:19:52 -050015S = "${WORKDIR}/git"
16
Marri Devender Rao7b823182017-06-08 03:17:36 -050017do_install() {
18
19 DEST=${D}${config_datadir}
20 install -d ${DEST}
21
22 ${bindir}/perl-native/perl \
23 ${bindir}/gen_ipmi_fru.pl \
Matt Spinler0a8ea632017-12-14 13:31:55 -060024 -i ${mrw_datadir}/${MRW_XML} \
Marri Devender Rao7b823182017-06-08 03:17:36 -050025 -m ${hostfw_datadir}/config.yaml \
26 -o ${DEST}/config.yaml
27}