Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | inherit python3-dir |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 2 | |
| 3 | PYTHON="${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN}" |
| 4 | EXTRANATIVEPATH += "${PYTHON_PN}-native" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 5 | DEPENDS_append = " ${PYTHON_PN}-native " |
| 6 | |
| 7 | # python-config and other scripts are using distutils modules |
| 8 | # which we patch to access these variables |
| 9 | export STAGING_INCDIR |
| 10 | export STAGING_LIBDIR |
| 11 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 12 | # suppress host user's site-packages dirs. |
| 13 | export PYTHONNOUSERSITE = "1" |
| 14 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 15 | # autoconf macros will use their internal default preference otherwise |
| 16 | export PYTHON |