blob: df8ab620c75f4e379b78c96ab0b9c8ca1b585025 [file] [log] [blame]
Brad Bishop23eaf032019-11-20 05:15:02 -05001SUMMARY = "GNOME editor"
2SECTION = "x11/gnome"
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=75859989545e37968a99b631ef42722e"
5
6GNOMEBASEBUILDCLASS = "meson"
7
8DEPENDS = " \
Brad Bishop23eaf032019-11-20 05:15:02 -05009 gdk-pixbuf-native \
Brad Bishop23eaf032019-11-20 05:15:02 -050010 gtk+3 \
11 gsettings-desktop-schemas \
Brad Bishop23eaf032019-11-20 05:15:02 -050012 libpeas \
13 libsoup-2.4 \
14 gspell \
15 gtksourceview4 \
Andrew Geissler89770b02020-06-13 10:40:47 -050016 tepl \
Brad Bishop23eaf032019-11-20 05:15:02 -050017"
18
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070019inherit gnomebase gsettings itstool gnome-help gobject-introspection gtk-doc vala gettext features_check mime-xdg python3targetconfig
20
21def gnome_verdir(v):
22 return oe.utils.trim_version(v, 1)
Brad Bishop23eaf032019-11-20 05:15:02 -050023
24REQUIRED_DISTRO_FEATURES = "x11"
25
Andrew Geissler595f6302022-01-24 19:11:47 +000026SRC_URI += " file://0001-Remove-incorrect-args-for-i18n.merge_file.patch"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070027SRC_URI[archive.sha256sum] = "55e394a82cb65678b1ab49526cf5bd43f00d8fba21476a4849051a8e137d3691"
28
29# gobject-introspection is mandatory and cannot be configured
30REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
Andrew Geissler595f6302022-01-24 19:11:47 +000031GIR_MESON_OPTION = ""
Brad Bishop23eaf032019-11-20 05:15:02 -050032
Andrew Geissler89770b02020-06-13 10:40:47 -050033GTKDOC_MESON_OPTION = "gtk_doc"
Brad Bishop23eaf032019-11-20 05:15:02 -050034
35PACKAGES += "${PN}-python"
36
Patrick Williams213cb262021-08-07 19:21:33 -050037FILES:${PN} += " \
Brad Bishop23eaf032019-11-20 05:15:02 -050038 ${datadir}/dbus-1 \
39 ${datadir}/metainfo \
40"
41
Patrick Williams213cb262021-08-07 19:21:33 -050042FILES:${PN}-python += " \
Brad Bishop23eaf032019-11-20 05:15:02 -050043 ${PYTHON_SITEPACKAGES_DIR} \
44"
45
Patrick Williams213cb262021-08-07 19:21:33 -050046RDEPENDS:${PN} += "gsettings-desktop-schemas"
47RRECOMMENDS:${PN} += "source-code-pro-fonts"