blob: e65739a5c7ac07f26f90e7e56694246b4e1f9e3b [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "tcpslice"
2DESCRIPTION = "A tool for extracting parts of a tcpdump packet trace."
3HOMEPAGE = "http://www.tcpdump.org/related.html"
4SECTION = "net"
5
6LICENSE = "BSD-4-Clause"
7LIC_FILES_CHKSUM = "file://tcpslice.c;endline=20;md5=99519e2e5234d1662a4ce16baa62c64e"
8
9SRC_URI = "ftp://ftp.ee.lbl.gov/${BP}.tar.gz \
10 file://tcpslice-1.2a3-time.patch \
11 file://tcpslice-CVS.20010207-bpf.patch \
12 "
13SRC_URI[md5sum] = "e329cbeb7e589f132d92c3447c477190"
14SRC_URI[sha256sum] = "4096e8debc898cfaa16b5306f1c42f8d18b19e30e60da8d4deb781c8f684c840"
15
16inherit autotools-brokensep
17
18DEPENDS += "libpcap"
19
20# We do not want to autoreconf. We must specify srcdir as ".".
21# We have to set the ac_cv_* cache variables as well as pass the normal
22# cross-compilation options to configure!
23#
24do_configure () {
Patrick Williamsddad1a12017-02-23 20:36:32 -060025 oe_runconf \
26 --srcdir="." \
27 ac_cv_build=${BUILD_SYS} \
28 ac_cv_host=${HOST_SYS} \
29 ac_cv_target=${HOST_SYS}
Patrick Williamsb48b7b42016-08-17 15:04:38 -050030}
31
32do_install () {
Patrick Williamsddad1a12017-02-23 20:36:32 -060033 mkdir -p ${D}/usr/sbin
34 install -c -m 555 tcpslice ${D}/usr/sbin
Patrick Williamsb48b7b42016-08-17 15:04:38 -050035}
36