blob: c571013a911aaf687e13a97d51a2bf522e0208c7 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Phoronix Test Suite"
2DESCRIPTION = "The Phoronix Test Suite is designed to carry out both qualitative \
3and quantitative benchmarks in a clean, reproducible, and easy-to-use manner."
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6SECTION = "console/tests"
7
8SRC_URI = "http://www.phoronix-test-suite.com/releases/${BP}.tar.gz"
Brad Bishope42b3e32020-01-15 22:08:42 -05009SRC_URI[md5sum] = "ad80ed9a5835929138473f764ff0d5db"
10SRC_URI[sha256sum] = "675e7ca96719e2f3b42a6c13421213a398f04da0f8e78f4691fa9261fdeb8501"
Brad Bishop19323692019-04-05 15:28:33 -040011
12S = "${WORKDIR}/phoronix-test-suite"
13
Andrew Geissler82c905d2020-04-13 13:39:40 -050014inherit systemd allarch mime mime-xdg
Brad Bishop19323692019-04-05 15:28:33 -040015
16do_install() {
17 DESTDIR=${D} ./install-sh ${exec_prefix}
18
19 if [ "${systemd_unitdir}" != "/usr/lib/systemd" ]; then
20 install -d ${D}/${systemd_unitdir}/system/
21 mv ${D}/usr/lib/systemd/system/* ${D}/${systemd_unitdir}/system/
22 rm -rf ${D}/usr/lib/
23 fi
24}
25
26# It is not advisable to enable these services by default since they can cause
27# continual target reboots if they encounter network problems.
28#
29SYSTEMD_AUTO_ENABLE = "disable"
Patrick Williams213cb262021-08-07 19:21:33 -050030SYSTEMD_SERVICE:${PN} = "phoromatic-client.service phoromatic-server.service"
Brad Bishop19323692019-04-05 15:28:33 -040031
Patrick Williams213cb262021-08-07 19:21:33 -050032RDEPENDS:${PN} += "bash python3-core php-cli util-linux-lscpu os-release lsb-release"
Brad Bishop19323692019-04-05 15:28:33 -040033
Patrick Williams213cb262021-08-07 19:21:33 -050034FILES:${PN} += " \
Brad Bishop19323692019-04-05 15:28:33 -040035 ${datadir}/phoronix-test-suite \
36 ${datadir}/appdata/phoronix-test-suite.appdata.xml \
37 ${datadir}/icons/hicolor/48x48/apps/phoronix-test-suite.png \
38 ${datadir}/icons/hicolor/64x64/mimetypes/application-x-openbenchmarking.png \
39 ${datadir}/mime/packages/openbenchmarking-mime.xml \
40 ${systemd_unitdir}/* \
41"