blob: 5504515e9888a7129a9e68c8267530766ae687e1 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Gnuplot is a portable command-line driven graphing utility"
2DESCRIPTION = "Gnuplot is a portable command-line driven interactive datafile \
3(text or binary) and function plotting utility."
4HOMEPAGE = "http://www.gnuplot.info/"
5SECTION = "console/scientific"
6LICENSE = "gnuplot"
7LIC_FILES_CHKSUM = "file://Copyright;md5=243a186fc2fd3b992125d60d5b1bab8f"
8DEPENDS = "${BPN}-native virtual/libx11 gd readline"
9
10inherit autotools features_check
11# depends on virtual/libx11
12REQUIRED_DISTRO_FEATURES = "x11"
13
14SRC_URI = " \
15 ${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${PV}/${BP}.tar.gz;name=archive \
16 http://www.mneuroth.de/privat/zaurus/qtplot-0.2.tar.gz;name=qtplot \
17 file://gnuplot.desktop \
18 file://gnuplot.png \
19"
20SRC_URI:append:class-target = " \
21 file://0002-do-not-build-demos.patch \
22 file://0003-Use-native-tools-to-build-docs.patch \
23 file://0004-Add-configure-option-to-find-qt5-native-tools.patch \
24"
25
26SRC_URI[archive.sha256sum] = "e57c75e1318133951d32a83bcdc4aff17fed28722c4e71f2305cfc2ae1cae7ba"
27SRC_URI[qtplot.sha256sum] = "6df317183ff62cc82f3dcf88207a267cd6478cb5147f55d7530c94f1ad5f4132"
28
29# for building docs (they deserve it) we need *doc2* tools native
30BBCLASSEXTEND = "native"
31DEPENDS:class-native = "readline-native"
32PACKAGECONFIG:class-native = ""
33
34SRC_URI:append:class-native = " file://0001-reduce-build-to-conversion-tools-for-native-build.patch"
35
36do_install:class-native() {
37 install -d ${D}${bindir}
38 install ${B}/docs/*doc* ${D}${bindir}
39 rm ${D}${bindir}/*.o
40}
41
42PACKAGECONFIG ??= "cairo"
43PACKAGECONFIG[cairo] = "--with-cairo,--without-cairo,cairo pango"
44PACKAGECONFIG[lua] = "--with-lua,--without-lua,lua"
45PACKAGECONFIG[qt5] = "--with-qt --with-qt5nativesysroot=${STAGING_DIR_NATIVE},--without-qt,qtbase-native qtbase qtsvg qttools-native"
46
47EXTRA_OECONF = " \
48 --with-readline=${STAGING_LIBDIR}/.. \
49 -disable-wxwidgets \
50"
51
52do_compile:prepend() {
53 install -m 0644 ${WORKDIR}/qtplot-0.2/qtopia.trm ${S}/term/
54}
55
56do_install:append:class-target() {
57 install -d ${D}${datadir}/applications/
58 install -m 0644 ${WORKDIR}/gnuplot.desktop ${D}${datadir}/applications/
59 install -d ${D}${datadir}/pixmaps/
60 install -m 0644 ${WORKDIR}/gnuplot.png ${D}${datadir}/pixmaps/
61}
62
63PACKAGES =+ "${PN}-x11"
64
65RPROVIDES:${PN}-dbg += "${PN}-x11-dbg"
66
67DESCRIPTION:${PN}-x11 = "X11 display terminal for Gnuplot."
68SECTION:${PN}-x11 = "x11/scientific"
69FILES:${PN}-x11 = "${libexecdir} ${datadir}/applications ${datadir}/pixmaps ${libdir}/X11 "
70
71FILES:${PN} += "${datadir}/texmf"