blob: dbf5d59d18d62b24e76fb8da87962645c4f449ee [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "mailx is the traditional command-line-mode mail user agent"
2
3DESCRIPTION = "Mailx is derived from Berkeley Mail and is intended provide the \
4functionality of the POSIX mailx command with additional support \
5for MIME, IMAP, POP3, SMTP, and S/MIME."
6
7HOMEPAGE = "http://heirloom.sourceforge.net/mailx.html"
8SECTION = "console/network"
9LICENSE = "BSD & MPL-1"
10LIC_FILES_CHKSUM = "file://COPYING;md5=4202a0a62910cf94f7af8a3436a2a2dd"
11
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012DEPENDS = "openssl"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013
14SRC_URI = "http://snapshot.debian.org/archive/debian/20160728T043443Z/pool/main/h/heirloom-mailx/heirloom-mailx_12.5.orig.tar.gz;name=archive \
15 file://0001-Don-t-reuse-weak-symbol-optopt-to-fix-FTBFS-on-mips.patch \
16 file://0002-Patched-out-SSL2-support-since-it-is-no-longer-suppo.patch \
17 file://0003-Fixed-Lintian-warning-warning-macro-N-not-defined.patch \
18 file://0011-outof-Introduce-expandaddr-flag.patch \
19 file://0012-unpack-Disable-option-processing-for-email-addresses.patch \
20 file://0013-fio.c-Unconditionally-require-wordexp-support.patch \
21 file://0014-globname-Invoke-wordexp-with-WRDE_NOCMD.patch \
22 file://0015-usr-sbin-sendmail.patch \
23 file://explicitly.disable.krb5.support.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024 file://0001-support-openssl-1.1.x.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050025 "
26
27SRC_URI[archive.md5sum] = "29a6033ef1412824d02eb9d9213cb1f2"
28SRC_URI[archive.sha256sum] = "015ba4209135867f37a0245d22235a392b8bbed956913286b887c2e2a9a421ad"
29
30# for this package we're mostly interested in tracking debian patches,
31# and not in the upstream version where all development has effectively stopped
32UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/h/heirloom-mailx/"
33UPSTREAM_CHECK_REGEX = "(?P<pver>((\d+\.*)+)-((\d+\.*)+))\.(diff|debian\.tar)\.(gz|xz)"
34
35S = "${WORKDIR}/heirloom-mailx-12.5"
36
37inherit autotools-brokensep
38
Patrick Williams213cb262021-08-07 19:21:33 -050039CFLAGS:append = " -D_BSD_SOURCE -DDEBIAN -I${S}/EXT"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050040
41# "STRIP=true" means that 'true' command will be used to 'strip' files which will achieve the effect of not stripping them
42# mailx's Makefile doesn't allow a more straightforward way to avoid stripping
43EXTRA_OEMAKE = "SENDMAIL=${sbindir}/sendmail IPv6=-DHAVE_IPv6_FUNCS PREFIX=/usr UCBINSTALL=/usr/bin/install STRIP=true"
44
45# The makeconfig can't run parallelly, otherwise the checking results
46# might be incorrect and lead to errors:
47# fio.c:56:17: fatal error: ssl.h: No such file or directory
48# #include <ssl.h>
49PARALLEL_MAKE = ""
50
51# Causes gcc to get stuck and eat all available memory in qemuarm builds
52# http://errors.yoctoproject.org/Errors/Details/20488/
Patrick Williams213cb262021-08-07 19:21:33 -050053ARM_INSTRUCTION_SET:armv4 = "arm"
54ARM_INSTRUCTION_SET:armv5 = "arm"