blob: 252ba9f3dc693ea1db5c2c53e7fad5ea1164d9c4 [file] [log] [blame]
William A. Kennington IIIb95905d2021-06-02 12:40:56 -07001#
2# Copyright (C) 2014 Wind River Systems, Inc.
3# Released under the BSD-3-Clause license (see COPYING.BSD-3 for the terms)
4#
5SUMMARY = "A compression/decompression library"
6DESCRIPTION = "Snappy is a fast data compression and decompression library \
7It was designed to be very fast and stable, but not to achieve a high \
8compression ratio."
9
10LICENSE = "BSD-3-Clause"
11LIC_FILES_CHKSUM = "file://COPYING;md5=f62f3080324a97b3159a7a7e61812d0c"
12
Andrew Geissler595f6302022-01-24 19:11:47 +000013SRC_URI = "gitsm://github.com/google/snappy.git;protocol=https;branch=master \
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070014 file://0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch \
15"
16SRCREV = "2b63814b15a2aaae54b7943f0cd935892fae628f"
17S = "${WORKDIR}/git"
18
19
20inherit cmake pkgconfig
21
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[lzo] = "-DHAVE_LIBLZO2=1,-DHAVE_LIBLZO2=0,lzo,"
24TARGET_CFLAGS += "-fPIC"
25
26EXTRA_OECMAKE += '-DBUILD_SHARED_LIBS="ON" -DSNAPPY_BUILD_TESTS="OFF" -DSNAPPY_BUILD_BENCHMARKS="OFF"'