blob: 9e1e787f10f1ed45aa4fd689b0387766249b58f3 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "A recursive directory listing command"
2HOMEPAGE = "http://mama.indstate.edu/users/ice/tree/"
3SECTION = "console/utils"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=393a5ca445f6965873eca0259a17f833"
6
7SRC_URI = "http://mama.indstate.edu/users/ice/tree/src/${BP}.tgz"
8SRC_URI[sha256sum] = "e3339c5a194cf6b4080f15ec59faa3679f02d5a793b2147912fbfcfb4cdf2239"
9
10# tree's default CFLAGS for Linux
11CFLAGS += "-Wall -DLINUX -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
12
13EXTRA_OEMAKE = "CC='${CC}' CFLAGS='${CFLAGS}' LDFLAGS='${LDFLAGS}'"
14
15do_configure[noexec] = "1"
16
17do_install() {
18 install -d ${D}${bindir}
19 install -m 0755 ${S}/${BPN} ${D}${bindir}/
20}