blob: 1bf5b207c135e0f5ec3bb2319f1ef512aec8747a [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Guess OpenSSL include path"
2SECTION = "libs"
3LICENSE = "Artistic-1.0 | GPL-1.0+"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=ea914cc2718e8d53bd7744d96e66c03c"
5
6SRC_URI = "http://www.cpan.org/modules/by-module/Crypt/Crypt-OpenSSL-Guess-${PV}.tar.gz "
7
8SRC_URI[sha256sum] = "e4331977e1512a3ba51d7fa2d642d3e79d479dc23483246ebfaaef80ea8573df"
9
10DEPENDS += "openssl"
11
12RDEPENDS:${PN} = "\
13 perl-module-config \
14 perl-module-exporter \
15 perl-module-extutils-mm \
16 perl-module-extutils-mm-unix \
17 perl-module-file-spec \
18 perl-module-symbol \
19 perl-module-strict \
20 perl-module-warnings \
21"
22
23EXTRA_CPANFLAGS = "INC='-I${STAGING_INCDIR}' LIBS='-L${STAGING_LIBDIR} -lssl -L${STAGING_DIR_TARGET}${base_libdir} -lcrypto'"
24
25S = "${WORKDIR}/Crypt-OpenSSL-Guess-${PV}"
26
27inherit cpan ptest-perl
28
29BBCLASSEXTEND = "native"
30
31# for backwards compatibility
32PROVIDES_${PN} += "libcrypt-openssl-guess"
33
34RDEPENDS:${PN}-ptest += "\
35 perl-module-test-more \
36"