blob: ef7fd08bfe0cd79edcbf064f3eb2e9c5d27956c3 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Perl library for transparent SSL"
2DESCRIPTION = "This module is a true drop-in replacement for IO::Socket::INET that \
3uses SSL to encrypt data before it is transferred to a remote server \
4or client. IO::Socket::SSL supports all the extra features that one \
5needs to write a full-featured SSL client or server application: \
6multiple SSL contexts, cipher selection, certificate verification, and \
7SSL version selection. As an extra bonus, it works perfectly with \
8mod_perl."
9HOMEPAGE = "http://search.cpan.org/dist/IO-Socket-SSL/"
10SECTION = "libs"
11
12LICENSE = "Artistic-1.0|GPLv1+"
13LIC_FILES_CHKSUM = "file://META.yml;beginline=12;endline=12;md5=963ce28228347875ace682de56eef8e8"
14
15RDEPENDS:${PN} += "\
16 libnet-ssleay-perl \
17 perl-module-autoloader \
18 perl-module-scalar-util \
19 perl-module-io-socket \
20"
21
22SRC_URI = "http://search.cpan.org/CPAN/authors/id/S/SU/SULLR/IO-Socket-SSL-${PV}.tar.gz \
23 file://run-ptest \
24 "
25SRC_URI[sha256sum] = "b2c0b34df97cb1aa816221cee2454a1efd89b86ccbda810389a30e0d08cf57c8"
26
27S = "${WORKDIR}/IO-Socket-SSL-${PV}"
28
29inherit cpan ptest
30
31do_install:append () {
32 mkdir -p ${D}${docdir}/${PN}/
33 cp ${S}/BUGS ${D}${docdir}/${PN}/
34 cp ${S}/Changes ${D}${docdir}/${PN}/
35 cp ${S}/README ${D}${docdir}/${PN}/
36 cp -pRP ${S}/docs ${D}${docdir}/${PN}/
37 cp -pRP ${S}/certs ${D}${docdir}/${PN}/
38 cp -pRP ${S}/example ${D}${docdir}/${PN}/
39}
40
41do_install_ptest () {
42 cp -r ${B}/t ${D}${PTEST_PATH}
43 cp -r ${B}/certs ${D}${PTEST_PATH}
44}
45
46BBCLASSEXTEND = "native"