blob: 5e847497ad383279ee330bdb700847282c2af08d [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "A python package that provides useful locks."
2HOMEPAGE = "https://github.com/harlowja/fasteners"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=4476c4be31402271e101d9a4a3430d52"
5
6SRC_URI[sha256sum] = "2aceacb2bd618ce8526676f7a3e84ea25d0165ef10abb574a45b4a9c07292d2e"
7
8inherit pypi setuptools3
9
10RDEPENDS:${PN} += "\
11 ${PYTHON_PN}-logging \
12 ${PYTHON_PN}-fcntl \
13"
14
15do_compile:prepend() {
16 echo "from setuptools import setup" > ${S}/setup.py
17 echo "setup()" >> ${S}/setup.py
18}