blob: e3f1df3562690dcdc9d7ad461bce7876e2d8470f [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "A microframework based on Werkzeug, Jinja2 and good intentions"
2DESCRIPTION = "\
3Flask is a microframework for Python based on Werkzeug, Jinja 2 and good \
4intentions. And before you ask: It’s BSD licensed!"
5HOMEPAGE = "https://github.com/mitsuhiko/flask/"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
8
9SRC_URI[sha256sum] = "7b2fb8e934ddd50731893bdcdb00fc8c0315916f9fcd50d22c7cc1a95ab634e2"
10
11PYPI_PACKAGE = "Flask"
12
13inherit pypi setuptools3
14
15CLEANBROKEN = "1"
16
17RDEPENDS:${PN} = " \
18 ${PYTHON_PN}-werkzeug \
19 ${PYTHON_PN}-jinja2 \
20 ${PYTHON_PN}-itsdangerous \
21 ${PYTHON_PN}-click \
22 ${PYTHON_PN}-profile \
23"