blob: 254787539508781314511c2a921226e50f304efc [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "pandas library for high-performance data analysis tools"
2DESCRIPTION = "pandas is an open source, BSD-licensed library providing \
3high-performance, easy-to-use data structures and data analysis tools for \
4the Python programming language."
5HOMEPAGE = "http://pandas.pydata.org/"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=3f23c5c092b74d245d48eeef72bc3fd2"
8
9SRC_URI[sha256sum] = "1e4285f5de1012de20ca46b188ccf33521bff61ba5c5ebd78b4fb28e5416a9f1"
10
11inherit pypi setuptools3
12
13DEPENDS += " \
14 ${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \
15"
16
17CFLAGS:append:toolchain-clang = " -Wno-error=deprecated-declarations"
18
19RDEPENDS:${PN} += " \
20 ${PYTHON_PN}-json \
21 ${PYTHON_PN}-numpy \
22 ${PYTHON_PN}-dateutil \
23 ${PYTHON_PN}-dateutil-zoneinfo \
24 ${PYTHON_PN}-pytz \
25 ${PYTHON_PN}-profile \
26"