blob: b535951c00449f71a08e8204044820c651e5467d [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
2application developers the full power and flexibility of SQL"
3HOMEPAGE = "http://www.sqlalchemy.org/"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3359ed561ac16aaa25b6c6eff84df595"
6
7SRC_URI[sha256sum] = "fa2bad14e1474ba649cfc969c1d2ec915dd3e79677f346bbfe08e93ef9020b39"
8
9PYPI_PACKAGE = "SQLAlchemy"
10inherit pypi setuptools3
11
12RDEPENDS:${PN} += " \
13 ${PYTHON_PN}-json \
14 ${PYTHON_PN}-pickle \
15 ${PYTHON_PN}-logging \
16 ${PYTHON_PN}-netclient \
17 ${PYTHON_PN}-numbers \
18 ${PYTHON_PN}-threading \
19 ${PYTHON_PN}-compression \
20 ${PYTHON_PN}-profile \
21"
22
23BBCLASSEXTEND = "native nativesdk"