blob: 8656d75c7975ec6a887dc971a14dd40e7c70825a [file] [log] [blame]
Andrew Geissler3e34fba2021-03-05 15:21:55 -06001SUMMARY = "CircuitPython driver for motor, stepper, and servo based on PCA9685."
2HOMEPAGE = "https://github.com/adafruit/Adafruit_CircuitPython_PCA9685"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e7eb6b599fb0cfb06485c64cd4242f62"
5
Andrew Geissler595f6302022-01-24 19:11:47 +00006SRC_URI = "git://github.com/adafruit/Adafruit_CircuitPython_PCA9685.git;branch=main;protocol=https"
Andrew Geissler3e34fba2021-03-05 15:21:55 -06007SRCREV = "2780c4102f4c23fbab252aa1198b61ba7e2d1b2c"
8
9S = "${WORKDIR}/git"
10
11inherit setuptools3
12
13DEPENDS += "python3-setuptools-scm-native"
14
Patrick Williams213cb262021-08-07 19:21:33 -050015RDEPENDS:${PN} += " \
Andrew Geissler3e34fba2021-03-05 15:21:55 -060016 python3-adafruit-blinka \
17 python3-adafruit-circuitpython-busdevice \
18 python3-adafruit-circuitpython-register \
19 python3-core \
20"