blob: dc794228ffe7147d9d6352f43f69feba73a8ff13 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# anonymous support class from originally from angstrom
2#
3# To use the blacklist, a distribution should include this
4# class in the INHERIT_DISTRO
5#
6# No longer use ANGSTROM_BLACKLIST, instead use a table of
7# recipes in PNBLACKLIST
8#
9# Features:
10#
11# * To add a package to the blacklist, set:
12# PNBLACKLIST[pn] = "message"
13#
14
Patrick Williamsc124f4f2015-09-15 14:41:29 -050015python () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050016 blacklist = d.getVarFlag('PNBLACKLIST', d.getVar('PN'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017
18 if blacklist:
Brad Bishop316dfdd2018-06-25 12:45:53 -040019 raise bb.parse.SkipRecipe("Recipe is blacklisted: %s" % (blacklist))
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020}