blob: 1db0065a375eedd87472bf295b5b8b8364938514 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Embedded Linux Library"
2HOMEPAGE = "https://01.org/ell"
3DESCRIPTION = "The Embedded Linux Library (ELL) provides core, \
4low-level functionality for system daemons. It typically has no \
5dependencies other than the Linux kernel, C standard library, and \
6libdl (for dynamic linking). While ELL is designed to be efficient \
7and compact enough for use on embedded Linux platforms, it is not \
8limited to resource-constrained systems."
9SECTION = "libs"
10LICENSE = "LGPLv2.1"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
12
13DEPENDS = "dbus"
14
15inherit autotools pkgconfig
16
17SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/libs/${BPN}/${BPN}-${PV}.tar.xz \
18 "
19SRC_URI[sha256sum] = "4901a0baac4eb24163ceafb44fd448430361d25d8f17d89ff29f8b0b162b3eb9"
20
21do_configure:prepend () {
22 mkdir -p ${S}/build-aux
23}