blob: cc50f90f70bcb3983d3cd998b5d95d5dda9b4ad8 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "A stream-oriented XML parser library"
2DESCRIPTION = "Expat is an XML parser library written in C. It is a stream-oriented parser in which an application registers handlers for things the parser might find in the XML document (like start tags)"
3HOMEPAGE = "https://github.com/libexpat/libexpat"
4SECTION = "libs"
5LICENSE = "MIT"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=9e2ce3b3c4c0f2670883a23bbd7c37a9"
8
9VERSION_TAG = "${@d.getVar('PV').replace('.', '_')}"
10
11SRC_URI = "https://github.com/libexpat/libexpat/releases/download/R_${VERSION_TAG}/expat-${PV}.tar.bz2 \
12 file://run-ptest \
13 "
14
15UPSTREAM_CHECK_URI = "https://github.com/libexpat/libexpat/releases/"
16
17SRC_URI[sha256sum] = "6f262e216a494fbf42d8c22bc841b3e117c21f2467a19dc4c27c991b5622f986"
18
19EXTRA_OECMAKE:class-native += "-DEXPAT_BUILD_DOCS=OFF"
20
21RDEPENDS:${PN}-ptest += "bash"
22
23inherit cmake lib_package ptest
24
25do_install_ptest:class-target() {
26 install -m 755 ${B}/tests/* ${D}${PTEST_PATH}
27}
28
29BBCLASSEXTEND += "native nativesdk"
30
31CVE_PRODUCT = "expat libexpat"