blob: c37814ee24e2708a9bd552e404e2fa87782438db [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Cross locale generation tool for glibc"
2HOMEPAGE = "http://www.gnu.org/software/libc/libc.html"
3SECTION = "libs"
4LICENSE = "LGPL-2.1"
5
6LIC_FILES_CHKSUM = "file://LICENSES;md5=1541fd8f5e8f1579512bf05f533371ba \
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
9 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
10
11require glibc-version.inc
12
13# Tell autotools that we're working in the localedef directory
14#
15AUTOTOOLS_SCRIPT_PATH = "${S}/localedef"
16
Andrew Geissler82c905d2020-04-13 13:39:40 -050017inherit autotools
Andrew Geisslerd1e89492021-02-12 15:35:20 -060018inherit native
Andrew Geissler82c905d2020-04-13 13:39:40 -050019
20FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:${FILE_DIRNAME}/glibc:"
21
22SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
Andrew Geissler595f6302022-01-24 19:11:47 +000023 git://github.com/kraj/localedef;branch=master;name=localedef;destsuffix=git/localedef;protocol=https \
Andrew Geissler82c905d2020-04-13 13:39:40 -050024 \
Andrew Geissler82c905d2020-04-13 13:39:40 -050025 file://0001-localedef-Add-hardlink-resolver-from-util-linux.patch \
26 file://0002-localedef-fix-ups-hardlink-to-make-it-compile.patch \
27 \
Patrick Williams0ca19cc2021-08-16 14:03:13 -050028 file://0018-Remove-bash-dependency-for-nscd-init-script.patch \
29 file://0019-eglibc-Cross-building-and-testing-instructions.patch \
30 file://0020-eglibc-Help-bootstrap-cross-toolchain.patch \
31 file://0021-eglibc-Resolve-__fpscr_values-on-SH4.patch \
32 file://0022-eglibc-Forward-port-cross-locale-generation-support.patch \
33 file://0024-localedef-add-to-archive-uses-a-hard-coded-locale-pa.patch \
Andrew Geissler595f6302022-01-24 19:11:47 +000034 file://0001-Make-shell-interpreter-overridable-in-tzselect.ksh.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050035"
36# Makes for a rather long rev (22 characters), but...
37#
38SRCREV_FORMAT = "glibc_localedef"
39
40S = "${WORKDIR}/git"
41
42EXTRA_OECONF = "--with-glibc=${S}"
Andrew Geissler595f6302022-01-24 19:11:47 +000043
44# We do not need bash to run tzselect script, the default is to use
45# bash but it can be configured by setting KSHELL Makefile variable
46EXTRA_OEMAKE += "KSHELL=/bin/sh"
47
Andrew Geissler82c905d2020-04-13 13:39:40 -050048CFLAGS += "-fgnu89-inline -std=gnu99 -DIS_IN\(x\)='0'"
49
50do_install() {
51 install -d ${D}${bindir}
52 install -m 0755 ${B}/localedef ${D}${bindir}/cross-localedef
53 install -m 0755 ${B}/cross-localedef-hardlink ${D}${bindir}/cross-localedef-hardlink
54}