blob: b79ce61fbff3d1034d1b8700f1bd74c053fb6f9d [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "A sophisticated Numeric Processing Package for Python"
2HOMEPAGE = "https://numpy.org/"
3DESCRIPTION = "NumPy is the fundamental package needed for scientific computing with Python."
4SECTION = "devel/python"
5LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF & Apache-2.0 & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8026691468924fb6ec155dadfe2a1a7f"
7
8SRCNAME = "numpy"
9
10SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
11 file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
12 file://0001-numpy-core-Define-RISCV-32-support.patch \
13 file://run-ptest \
14 file://0001-numpy-core-setup.py-disable-svml-for-now.patch \
15 "
16SRC_URI[sha256sum] = "dd1968402ae20dfd59b34acd799b494be340c774f6295e9bf1c2b9842a5e416d"
17
18UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases"
19UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
20
21DEPENDS += "python3-cython-native"
22
23inherit ptest setuptools3
24
25S = "${WORKDIR}/numpy-${PV}"
26
27CLEANBROKEN = "1"
28
29FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a"
30
31# install what is needed for numpy.test()
32RDEPENDS:${PN} = "${PYTHON_PN}-unittest \
33 ${PYTHON_PN}-difflib \
34 ${PYTHON_PN}-pprint \
35 ${PYTHON_PN}-pickle \
36 ${PYTHON_PN}-shell \
37 ${PYTHON_PN}-doctest \
38 ${PYTHON_PN}-datetime \
39 ${PYTHON_PN}-distutils \
40 ${PYTHON_PN}-misc \
41 ${PYTHON_PN}-mmap \
42 ${PYTHON_PN}-netclient \
43 ${PYTHON_PN}-numbers \
44 ${PYTHON_PN}-pydoc \
45 ${PYTHON_PN}-pkgutil \
46 ${PYTHON_PN}-email \
47 ${PYTHON_PN}-compression \
48 ${PYTHON_PN}-ctypes \
49 ${PYTHON_PN}-threading \
50 ${PYTHON_PN}-multiprocessing \
51 ${PYTHON_PN}-json \
52"
53RDEPENDS:${PN}-ptest += "${PYTHON_PN}-pytest \
54 ${PYTHON_PN}-hypothesis \
55 ${PYTHON_PN}-sortedcontainers \
56 ${PYTHON_PN}-resource \
57 ldd \
58"
59
60BBCLASSEXTEND = "native nativesdk"