blob: a6bee1bea1b9ab07a2cfd093bb7165e6129c7098 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order."
2HOMEPAGE = "https://pypi.org/project/ruamel.yaml/"
3AUTHOR = "Anthon van der Neut"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=034154b7344d15438bc5ed5ee9cc075f"
7
8PYPI_PACKAGE = "ruamel.yaml"
9
10inherit pypi setuptools3
11
12SRC_URI[sha256sum] = "4b8a33c1efb2b443a93fcaafcfa4d2e445f8e8c29c528d9f5cdafb7cc9e4004c"
13
14RDEPENDS:${PN} += "\
15 ${PYTHON_PN}-shell \
16 ${PYTHON_PN}-datetime \
17 ${PYTHON_PN}-netclient \
18"
19
20do_install:prepend() {
21 export RUAMEL_NO_PIP_INSTALL_CHECK=1
22}
23
24BBCLASSEXTEND = "native nativesdk"