blob: aa23ad856d86e0ec174b913844de934379356bd4 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "A lil' TOML parser"
2DESCRIPTION = "Tomli is a Python library for parsing TOML. Tomli is fully \
3compatible with TOML v1.0.0."
4HOMEPAGE = "https://github.com/hukkin/tomli"
5BUGTRACKER = "https://github.com/hukkin/tomli/issues"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=aaaaf0879d17df0110d1aa8c8c9f46f5"
8
9inherit pypi setuptools3
10
11SRC_URI[sha256sum] = "c292c34f58502a1eb2bbb9f5bbc9a5ebc37bee10ffb8c2d6bbdfa8eb13cc14e1"
12
13do_configure:prepend() {
14cat > ${S}/setup.py <<-EOF
15from setuptools import setup
16setup(name="tomli", version="${PV}", packages=["tomli"], package_data={"": ["*"]})
17EOF
18}
19
20BBCLASSEXTEND = "native nativesdk"