blob: b56559fd9aa6c8d150c8900bab0b2bc47e6f5df9 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001# SPDX-License-Identifier: MIT
2# Copyright (C) 2021 iris-GmbH infrared & intelligent sensors
3
4SUMMARY = "Tool for managing many Git repositories"
5DESCRIPTION = "Repo is a tool built on top of Git. Repo helps manage many Git repositories, does the uploads to revision control systems, and automates parts of the development workflow."
6HOMEPAGE = "https://android.googlesource.com/tools/repo"
7SECTION = "console/utils"
8
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
12SRC_URI = "git://gerrit.googlesource.com/git-repo.git;protocol=https;branch=main \
13 file://0001-python3-shebang.patch \
14 "
15SRCREV = "98bb76577d9e7e0ffdeb643f1654ec006f6bbc8c"
16
17MIRRORS += "git://gerrit.googlesource.com/git-repo.git git://github.com/GerritCodeReview/git-repo.git"
18
19S = "${WORKDIR}/git"
20
21do_set_fixed_rev() {
22 sed -Ei "s/REPO_REV\s*=\s*('|\")stable('|\")/REPO_REV = '${SRCREV}'/g" ${S}/repo
23}
24
25do_patch[postfuncs] += "do_set_fixed_rev"
26
27do_install() {
28 install -D ${WORKDIR}/git/repo ${D}${bindir}/repo
29}
30
31RDEPENDS:${PN} = "python3 git"
32
33BBCLASSEXTEND = "native nativesdk"