blob: addf652d520c7ef90fc3ad3c1155078b5cb8f5e7 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Line-oriented text editor"
2HOMEPAGE = "http://www.gnu.org/software/ed/"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05003DESCRIPTION = "GNU ed is a line-oriented text editor. It is used to create, display, modify and otherwise manipulate text files, both interactively and via shell scripts. A restricted version of ed, red, can only edit files in the current directory and cannot execute shell commands."
Andrew Geissler82c905d2020-04-13 13:39:40 -05004
5LICENSE = "GPLv3+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=0c7051aef9219dc7237f206c5c4179a7 \
Andrew Geisslerd1e89492021-02-12 15:35:20 -06007 file://ed.h;endline=20;md5=b72aa5eaafef318c6bfc37f858469113 \
8 file://main.c;endline=17;md5=2c93e24f4db3528a00a24c7df5618e41 \
Andrew Geissler82c905d2020-04-13 13:39:40 -05009 "
10
11SECTION = "base"
12
13CVE_PRODUCT = "gnu:ed"
14
15# LSB states that ed should be in /bin/
16bindir = "${base_bindir}"
17
18# Upstream regularly removes previous releases from https://ftp.gnu.org/gnu/ed/
19SRC_URI = "${GNU_MIRROR}/ed/${BP}.tar.lz"
20UPSTREAM_CHECK_URI = "${GNU_MIRROR}/ed/"
21
Andrew Geisslerd1e89492021-02-12 15:35:20 -060022SRC_URI[sha256sum] = "71de39883c25b6fab44add80635382a10c9bf154515b94729f4a6529ddcc5e54"
Andrew Geissler82c905d2020-04-13 13:39:40 -050023
24EXTRA_OEMAKE = "-e MAKEFLAGS="
25
26inherit texinfo
27
28do_configure() {
29 ${S}/configure
30}
31
32do_install() {
33 oe_runmake 'DESTDIR=${D}' install
34 # Info dir listing isn't interesting at this point so remove it if it exists.
35 if [ -e "${D}${infodir}/dir" ]; then
36 rm -f ${D}${infodir}/dir
37 fi
38}