blob: 0faf18f5a4e53c1e185b775eeeac18035f2f6738 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001DESCRIPTION = "A master image to be deployed on a target useful for testing other images"
2
3IMAGE_FEATURES += "ssh-server-openssh package-management"
4
5inherit core-image
6
7# the deploy code requires bash and
8# normal linux utilities not busybox ones
9IMAGE_INSTALL += "\
10 bash coreutils util-linux tar gzip bzip2 kmod \
Andrew Geissler82c905d2020-04-13 13:39:40 -050011 python3-modules python3-misc \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012 e2fsprogs e2fsprogs-mke2fs parted \
13 "
14# we need a particular initramfs for live images
15# that pulls custom install scripts which take
16# care of partitioning for us
17INITRD_IMAGE = "core-image-testmaster-initramfs"
18